summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-27 09:11:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-27 10:12:06 +0200
commit859c70982400992d7c15baf2a7a4a2e4710ad7e9 (patch)
treea29baeb3647bf5b3f5354332efb1f1ec75105056
parentdev-python/sqlalchemy: Bump to 1.4.36 (diff)
downloadgentoo-859c7098.tar.gz
gentoo-859c7098.tar.bz2
gentoo-859c7098.zip
dev-python/trimesh: Bump to 3.11.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-3.11.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index fa5c897f55c6..7ca14cfd3d49 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1 +1,2 @@
DIST trimesh-3.10.8.gh.tar.gz 10741790 BLAKE2B 2cc8573e01395fb95f192cd64370b32d63b3ebd3505008c67fc9530641060b127ff42b8892634bf61fd91dbc37098e0da9fa169199d257a0345494cf9996a764 SHA512 c5cd6a6abcf8b8e6cc157a76607d4db090c574a86450956577d81fff310448bab140007eefc3b2c2cea6873a1ef46eccb18834c1593aca40f3d7868b3ce3992e
+DIST trimesh-3.11.2.gh.tar.gz 10745738 BLAKE2B 59a13c2133f7cb0ad22ca5b03af9e61c4cc1431e8d058566b854240fe0b1e28229c427c69aa16aec8b79f139a0c2a3c5202ce2f6d4750f813325e591e3a671b2 SHA512 f9b3643c221ab3f112d4c5cf07c8cf23c5809d7c0ea733b6cda0efc973a78fb4ebd8be9cd0f52bb65babeb5a3dc448b15b738f3089fffb8a32c1af1b01dc8da0
diff --git a/dev-python/trimesh/trimesh-3.11.2.ebuild b/dev-python/trimesh/trimesh-3.11.2.ebuild
new file mode 100644
index 000000000000..a3816df1ff09
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.11.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+# No tests in PyPI tarballs
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}