summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-02 09:56:14 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-02 12:47:12 +0100
commit85bc7f4d76a8aea208771894c6917f2d2a3610ad (patch)
tree063d1c115a0c68e1c0a54e4f8bbaa05fc35b8cd4
parentdev-python/testrepository: Backport test fixes (diff)
downloadgentoo-85bc7f4d76a8aea208771894c6917f2d2a3610ad.tar.gz
gentoo-85bc7f4d76a8aea208771894c6917f2d2a3610ad.tar.bz2
gentoo-85bc7f4d76a8aea208771894c6917f2d2a3610ad.zip
dev-python/pillowfight: New package written by me
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/pillowfight/Manifest1
-rw-r--r--dev-python/pillowfight/metadata.xml5
-rw-r--r--dev-python/pillowfight/pillowfight-0.2.ebuild23
3 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pillowfight/Manifest b/dev-python/pillowfight/Manifest
new file mode 100644
index 000000000000..5678da7124f3
--- /dev/null
+++ b/dev-python/pillowfight/Manifest
@@ -0,0 +1 @@
+DIST pillowfight-0.2.tar.gz 2628 SHA256 15bce1925a3d66940ceb9a33c3c55de8d95462ce136c4d46e8673f2919b401d6 SHA512 2eff2fd0bdf5c02513ddb4838675e7b9f392135ff08a784ca2fedf06c5b96a56af75460559066cc6cded65f3d4da087ac679492b7b1dba23fb557e6ac3565e6e WHIRLPOOL 691e985dd6e8da23d117f1a826a99c1cf80fbe01e4e82be10b1cac1277be292ffb4be233e31c7ea4daf98c1c28af1be7d28a5f43e8535c176b15c7cb180f0e10
diff --git a/dev-python/pillowfight/metadata.xml b/dev-python/pillowfight/metadata.xml
new file mode 100644
index 000000000000..ee7e8b2450a8
--- /dev/null
+++ b/dev-python/pillowfight/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pillowfight/pillowfight-0.2.ebuild b/dev-python/pillowfight/pillowfight-0.2.ebuild
new file mode 100644
index 000000000000..7ffeb1c10f1b
--- /dev/null
+++ b/dev-python/pillowfight/pillowfight-0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Eases the transition from PIL to Pillow"
+HOMEPAGE="https://pypi.python.org/pypi/pillowfight/ https://github.com/beanbaginc/pillowfight"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"