summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-12-15 14:24:37 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-12-15 14:32:11 +0100
commit85bd5bda28af18f685637c5c15faf579dbaf16fd (patch)
tree86688824b0e2878f885c31741ea507acdb68bd75
parentdev-cpp/eigen: Disable cholmod tests through cmake.eclass (diff)
downloadgentoo-85bd5bda28af18f685637c5c15faf579dbaf16fd.tar.gz
gentoo-85bd5bda28af18f685637c5c15faf579dbaf16fd.tar.bz2
gentoo-85bd5bda28af18f685637c5c15faf579dbaf16fd.zip
www-client/firefox: don't use ac_add_options to set MOZ_OBJDIR
Bring back mozconfig_add_options_mk. Closes: https://bugs.gentoo.org/760033 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-client/firefox/firefox-84.0.ebuild18
1 files changed, 17 insertions, 1 deletions
diff --git a/www-client/firefox/firefox-84.0.ebuild b/www-client/firefox/firefox-84.0.ebuild
index 11727f10df3e..6d3e1b6e40d8 100644
--- a/www-client/firefox/firefox-84.0.ebuild
+++ b/www-client/firefox/firefox-84.0.ebuild
@@ -326,6 +326,22 @@ mozconfig_add_options_ac() {
done
}
+mozconfig_add_options_mk() {
+ debug-print-function ${FUNCNAME} "$@"
+
+ if [[ ${#} -lt 2 ]] ; then
+ die "${FUNCNAME} requires at least two arguments"
+ fi
+
+ local reason=${1}
+ shift
+
+ local option
+ for option in ${@} ; do
+ echo "mk_add_options ${option} # ${reason}" >>${MOZCONFIG}
+ done
+}
+
mozconfig_use_enable() {
debug-print-function ${FUNCNAME} "$@"
@@ -793,7 +809,7 @@ src_configure() {
mozconfig_add_options_ac 'Gentoo default' "XARGS=${EPREFIX}/usr/bin/xargs"
# Set build dir
- mozconfig_add_options_ac 'Gentoo default' "MOZ_OBJDIR=${BUILD_DIR}"
+ mozconfig_add_options_mk 'Gentoo default' "MOZ_OBJDIR=${BUILD_DIR}"
# Show flags we will use
einfo "Build CFLAGS: ${CFLAGS}"