summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-28 13:04:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-28 14:53:30 +0100
commit85beee8de42f6630a2c11643e38d871fb78620fe (patch)
treea2f8ff7758edab15a22f4ef228281003d727b31f
parentkde-apps/cervisia: 24.02.0 version bump (diff)
downloadgentoo-85beee8de42f6630a2c11643e38d871fb78620fe.tar.gz
gentoo-85beee8de42f6630a2c11643e38d871fb78620fe.tar.bz2
gentoo-85beee8de42f6630a2c11643e38d871fb78620fe.zip
kde-apps/dolphin-plugins-git: 24.02.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-24.02.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index f90748faacdb..e679b7bdf189 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1,3 +1,4 @@
DIST dolphin-plugins-23.04.3.tar.xz 272912 BLAKE2B f0eb8bbab16d66f1e964131b436af7d3ae8febc26cf4fe394489a978c701ef2f5689bea7daf9eed8d7ef2f1f2bdba000a487cf7f0704ad30bd25e2d403ce5fae SHA512 8f487ba0bcbe561915064247ddb2327c3b7c8fa6ffc5c511d9c9ef37bd4f28a624533ce7a2da2a86b10b65f37915ca10840517872b40c2fd014cead6da5972c8
DIST dolphin-plugins-23.08.4.tar.xz 274180 BLAKE2B 586c697b5c292ed78e826b1adabb26ee1daebe995d8fac4fc64bbc84c4490387a8100f895934783180da02ad9f008c0ef98b938e8f0cb6b1a8c1dd5be31b7c1f SHA512 7cb3365221aabe411e1339230633a37d674c6e2a77e675f8a1d9c61928bd0d2b75e5d289ba8d7765bcbea47afea56e2b629726fbdcf6e0e4248c4380ce33f40e
DIST dolphin-plugins-23.08.5.tar.xz 274124 BLAKE2B c8b43bd7f87c7221023e75e3f66b450844b379d5bfc95e37ce01dfe983ba3dc234a319da2aaf0596e6eb54319bc4310c718b57d52d070f0f86cd67c6f67a8c4b SHA512 2dd30070660df63b988cda2e14f3ddc27a0cf451119d2a6b121cb9cbeb8788b94498ef25ca434501843784a8e24c4539fe17cc0ab5a158befbc9db5792944852
+DIST dolphin-plugins-24.02.0.tar.xz 294220 BLAKE2B d2d2440ac4372218350f98a98b2aaeb1cdfd9fbfb2e9b8f05e5b0565dbe39948f488c837b9d63ec72162e3cbc0dc2badda592bec52e212ad49dee6fdf506c68c SHA512 0726c8b7988fa4252ad8b0b742f2e8611d9a6aadd020f45ccea93a4611c5b07493fa18f401ca86c31c42f1aafb9072556944d5dde9bd28930e6248fca65f19b2
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-24.02.0.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-24.02.0.ebuild
new file mode 100644
index 000000000000..121c2b8a45a2
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-24.02.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ >=dev-qt/qt5compat-${QTMIN}:6
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}