summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-10-14 08:54:12 +0200
committerHans de Graaff <graaff@gentoo.org>2023-10-14 08:54:24 +0200
commit85c099cd63cc3c1f6103b7ab4562158f3918d86a (patch)
treed894b8d8804e344dfaf5d00fc4d8b7e5b6696567
parentdev-ruby/actionmailer: add 7.1.1 (diff)
downloadgentoo-85c099cd63cc3c1f6103b7ab4562158f3918d86a.tar.gz
gentoo-85c099cd63cc3c1f6103b7ab4562158f3918d86a.tar.bz2
gentoo-85c099cd63cc3c1f6103b7ab4562158f3918d86a.zip
dev-ruby/actionmailbox: add 7.1.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/actionmailbox/Manifest1
-rw-r--r--dev-ruby/actionmailbox/actionmailbox-7.1.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-ruby/actionmailbox/Manifest b/dev-ruby/actionmailbox/Manifest
index 655ecd754075..8fc48fae7c9d 100644
--- a/dev-ruby/actionmailbox/Manifest
+++ b/dev-ruby/actionmailbox/Manifest
@@ -3,3 +3,4 @@ DIST rails-6.1.7.6.tgz 11040086 BLAKE2B 8b5311752952403cf8eae31b5d8e8d376c4b449f
DIST rails-7.0.7.2.tgz 11085454 BLAKE2B 05574b6df7e28e409949fb311110fd7137d61c31072b394f950a180135201132f3cf9c5cca8f76c661827d7a5e807bfc4b0c97a449b8941115cbe3a0f2f84f62 SHA512 41fad11bd272ea21f7d15d855da04230f0801d9926f6ce3300754f1b2b9d691f18e55855b1a71e44faaf483b397b02ac11c75eb415b7c8976868bc9aefe5b005
DIST rails-7.0.7.tgz 11071730 BLAKE2B 215642609be86bd9977dc2cdb09a76c64e99260359d0a60aa411a5df572d7699a5f9959ea8aa0ff116ad75110db060436abcfb17da689b1a6aa819fd56373279 SHA512 75f952dfe4d9abc1473dfb017e42daec6358a45efad14a3b39a1b2dc5fec566757c2225fe920a4e872e896966cfb1d4b6e1c40c93d2043aec3bf5bd25ff7c956
DIST rails-7.0.8.tgz 11073254 BLAKE2B 2aee047a365acb0890ef3afbccfe323fedccf7b54214aa1c2f92b7a7aaa64c275c1e03f8f97e6a2e30281224ba30703d18b40aeee9b4e7fb6f035a4a7716a054 SHA512 0e9feb5bd0360868c3109152d8ea414b65d36d33a5dbb96b199cfa6c4335800d6c392e0fbcbfa453a02fd75924a297a65caf04948895de53db43700478dbeb11
+DIST rails-7.1.1.tgz 10871844 BLAKE2B 12ebcb567f9a8eca58fa0a9c066a8c9c904130a514daa079be4625e0b0ef0ab5744d3dfbff01a146c9053a36ecb77e4f4d381ce8167ec511badcbba7f090b499 SHA512 9a18dc102acaaa1e66aa437ea3de2cc41acd04b7a52792fb686e88f14111a0e32e25a6d093f26badfdca2a932cf458720cbdb1efbcc00c766157741ea99a32f1
diff --git a/dev-ruby/actionmailbox/actionmailbox-7.1.1.ebuild b/dev-ruby/actionmailbox/actionmailbox-7.1.1.ebuild
new file mode 100644
index 000000000000..1837f346adc4
--- /dev/null
+++ b/dev-ruby/actionmailbox/actionmailbox-7.1.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailbox.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app config db"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activejob-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/mail-2.7.1:*
+ dev-ruby/net-imap
+ dev-ruby/net-pop
+ dev-ruby/net-smtp
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ <dev-ruby/minitest-5.16
+ dev-ruby/mocha
+ dev-ruby/propshaft
+ dev-ruby/rexml
+ dev-ruby/sqlite3
+ dev-ruby/webmock
+ dev-ruby/rails
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|webrick\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|rack-test\|capybara\|webpacker\|bootsnap\|dalli\|connection_pool\|terser\|cookiejar\|cgi\|web-console\|trilogy\|error_highlight\)/ s:^:#:" \
+ -e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
+ -e '/group :\(cable\|doc\|job\|lint\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
+ -e '/sqlite/ s/1.6.4/99/' \
+ -i ../Gemfile || die
+ rm ../Gemfile.lock || die
+ sed -i -e '/byebug/ s:^:#:' test/test_helper.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}