summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-08-12 10:39:25 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-08-12 10:41:44 -0500
commit85ea76c3d2272c1c7c81fb86279c4d7c591f5806 (patch)
tree5b0df92cb099be32d0eb04b80d87673bb5b50fa4
parentdev-python/josepy: 1.2.0 stable amd64 and x86 with cleanup (diff)
downloadgentoo-85ea76c3.tar.gz
gentoo-85ea76c3.tar.bz2
gentoo-85ea76c3.zip
app-crypt/acme: 0.36.0 stable amd64/x86 with cleanup
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-0.35.0.ebuild68
-rw-r--r--app-crypt/acme/acme-0.36.0.ebuild2
3 files changed, 1 insertions, 70 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index b51d00340383..6a90571bec86 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,3 +1,2 @@
-DIST certbot-0.35.0.tar.gz 1333065 BLAKE2B 8bd4fd735e68f24ee7c0533b18b63e2924eab9dcef78250f5d7094fbb04f78acca1c11cefae48e25da637a01a7dcd004f22926923b63a39206b63133193793a1 SHA512 ca94858aca5c6849dd6667d1e96389d80a7882de9a4deeda28d244ac105c1524dddb100dc899e4fabdef908607956617e26640b8e573b04a0625e19413c23bee
DIST certbot-0.36.0.tar.gz 1322339 BLAKE2B 69fbf68b5dd95d6d3ac6c868d583da8c66dfcd01e3471c511d0d9d95de08ac096479733e9fca12ca99abf43484835fa7184dcccb1c11a41ee7948174364f2894 SHA512 f7fa8c6200a76b4fc4830865bf11fbba8bd73ea55e1236680181073952505c83b4650b43ccfc8e9b96caf47b85c43e47acf8db6d92134f7c279ebd954ab0ac92
DIST certbot-0.37.0.tar.gz 1327246 BLAKE2B 917360ab6d9dedd6e5ea2c558822c228ff34617f97341b7d176e69f7589a3aa3012f1d9abdb33b72960c68a80b29987d1a7b1121eadd7d93adec5829b316f326 SHA512 3f2df5f591ba241719fe2e5e90c2b87e2d932d991d943eefbe00b9d76f7fb056d3b6026879511f591473c698b798e78645879f018a78e503b8a06280b036cb35
diff --git a/app-crypt/acme/acme-0.35.0.ebuild b/app-crypt/acme/acme-0.35.0.ebuild
deleted file mode 100644
index 9a9b63c8fa3c..000000000000
--- a/app-crypt/acme/acme-0.35.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- inherit git-r3
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
- S=${WORKDIR}/certbot-${PV}/acme
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the ACME protocol"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
- >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
- dev-python/pyrfc3339[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/requests-2.10[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
- >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
-"
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
- if use doc ; then
- cd docs || die
- sphinx-build -b html -d _build/doctrees . _build/html
- fi
-}
-
-python_test() {
- nosetests -w ${PN} || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/app-crypt/acme/acme-0.36.0.ebuild b/app-crypt/acme/acme-0.36.0.ebuild
index 3acd37f75f8e..9a9b63c8fa3c 100644
--- a/app-crypt/acme/acme-0.36.0.ebuild
+++ b/app-crypt/acme/acme-0.36.0.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999* ]]; then
S=${WORKDIR}/${P}/${PN}
else
SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
S=${WORKDIR}/certbot-${PV}/acme
fi