summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-30 22:35:59 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-30 22:40:48 +0200
commit85f3662c7ab309332e98518f52842594c75c532e (patch)
tree213187907c6b4697f74160406f19c08657150bf9
parentdev-python/jsonpatch: Remove old (diff)
downloadgentoo-85f3662c7ab309332e98518f52842594c75c532e.tar.gz
gentoo-85f3662c7ab309332e98518f52842594c75c532e.tar.bz2
gentoo-85f3662c7ab309332e98518f52842594c75c532e.zip
dev-python/jupyter_console: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyter_console/Manifest1
-rw-r--r--dev-python/jupyter_console/jupyter_console-6.0.0.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/jupyter_console/Manifest b/dev-python/jupyter_console/Manifest
index 2e173379d35b..c8e174ee38f5 100644
--- a/dev-python/jupyter_console/Manifest
+++ b/dev-python/jupyter_console/Manifest
@@ -1,2 +1 @@
-DIST jupyter_console-6.0.0.tar.gz 27780 BLAKE2B da2b58461caa987bea0b323cedbc79ff24f31cb928602b8ae6dce1ed615008a8227d7a1bab47364e6d182cfd3bd6f548e355430efc505e7183a391ef26c08375 SHA512 27b333f439733c33062d3baa8b49ff673b10e22cb8c28c688ba604799838e899f93372bd2eaf4a94c97260d6dec043d6aef4421388d77e625b1ec43a3dedfa3f
DIST jupyter_console-6.1.0.tar.gz 28468 BLAKE2B 08ef158de6a0eb8fe741dac00b74e11f7e577b5097f54aa16c47ae9e39607231e19a1fcd0a96cbae41d41fad891fefdb532d0f66bc03aa66ff99a8d3ff3cb28c SHA512 abb5457a90d109457e91071cd8b592a14bec7ead75fd667d656f9180a457e39bf470877b2e17c81ff512d1cc69b62a8f700996492f6164eb05a1581db82abbf7
diff --git a/dev-python/jupyter_console/jupyter_console-6.0.0.ebuild b/dev-python/jupyter_console/jupyter_console-6.0.0.ebuild
deleted file mode 100644
index 3ce4cef073ab..000000000000
--- a/dev-python/jupyter_console/jupyter_console-6.0.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- >=dev-python/prompt_toolkit-1.0.0[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/pexpect[${PYTHON_USEDEP}]
- >=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
- )
- "
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- nosetests --with-coverage --cover-package=jupyter_console jupyter_console || die
-}