summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-05-28 16:36:58 +0200
committerPacho Ramos <pacho@gentoo.org>2016-05-28 17:48:19 +0200
commit86122f7018f19890073e1307dfd3cb7a7eb60f75 (patch)
tree7260903b05423dc0bb8881375a02e8a284f75fab
parentmedia-gfx/eog-plugins: Drop old (diff)
downloadgentoo-86122f7018f19890073e1307dfd3cb7a7eb60f75.tar.gz
gentoo-86122f7018f19890073e1307dfd3cb7a7eb60f75.tar.bz2
gentoo-86122f7018f19890073e1307dfd3cb7a7eb60f75.zip
media-gfx/eog-plugins: Version bump
Package-Manager: portage-2.3.0_rc1
-rw-r--r--media-gfx/eog-plugins/Manifest1
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.16.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index bb6bffb74854..d582cc479376 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1 +1,2 @@
DIST eog-plugins-3.16.3.tar.xz 370528 SHA256 2d2198ed026b1c28329ac3d353b3031c2024277d81d60f3c1e626f4701a73bd2 SHA512 1ab8840147eadce718af9c8a7a5a9ddd99a30316ffbe31b57b24d8aa34e9908d83f95ed42e9ddc9368ebcc3eb8ea6e371232be8a015a771964178b02e7eb79b9 WHIRLPOOL efb351a9fbc9386bd527c4a0e9e9f3fb14274e1f129cd71bddb4e36132d5f4fbdf797d2bf962e442d6b2388c0ec219f52a9a588be99d0f124626e16633a54aa0
+DIST eog-plugins-3.16.4.tar.xz 394868 SHA256 4fcfe7df19cdf8e39f5fec599d7ff46bbd82842d49083274740fbbc51cf4d25e SHA512 bec368a2b23d2f0e270d1bebcfc52ec602a32fc1436478f115fe960dfbf73dafa4217589e1e49d2c299672f755a22aaae3a78a353bac698c9e9d88487c7d2d41 WHIRLPOOL 7f862dddcba84f4c50618e19424e4c140c3c83d26ed3c62667ff6f6beaf5ec2039add55448b4347121951bac3248dfad7e3d4ace3f1ea9417044cfb1ccbd05fe
diff --git a/media-gfx/eog-plugins/eog-plugins-3.16.4.ebuild b/media-gfx/eog-plugins/eog-plugins-3.16.4.ebuild
new file mode 100644
index 000000000000..eba12f855332
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.16.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_3,3_4,3_5} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif +flickr map picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ^^ ( $(python_gen_useflags '*') ) )"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.15.90
+ >=x11-libs/gtk+-3.14:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ flickr? ( media-gfx/postr )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.32:2[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use flickr && plugins="${plugins},postr"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}