summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-11-07 12:52:45 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-11-07 13:37:05 +0100
commit86192d32c395352743d0d33c353a848e3f80f9e9 (patch)
tree2765760f80fef3285ac1f0c4a830ee76e28351c7
parentdev-libs/intel-compute-runtime: drop old version (diff)
downloadgentoo-86192d32.tar.gz
gentoo-86192d32.tar.bz2
gentoo-86192d32.zip
dev-libs/intel-compute-runtime: bump to version 21.44.21506
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-21.44.21506.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 0f3ba5f721c1..1d25463969f1 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -2,3 +2,4 @@ DIST intel-compute-runtime-21.40.21182.tar.gz 4678271 BLAKE2B c8f5c324af0e8ef787
DIST intel-compute-runtime-21.41.21220.tar.gz 4753783 BLAKE2B a340c2b5c1199498a68aa66c1d88367b99bc2404f35da10135030aa68462a909808fb2358dbc3d75357e00ccf30bb259a325a3d4523d862c0da358eae7528f65 SHA512 df397688423dbe0ec2e61c9a9c8b6ee1ee4451a95ef01aefcc2a0ed956e6b8273a4e9975c9aca592b51b4ce85324f5bdcd6a835f8eab40a0e715eb10000f1ceb
DIST intel-compute-runtime-21.42.21270.tar.gz 4761371 BLAKE2B 5dd2886e4b2a84a2247d2bb70667805531f099881431d9e8052c870d4081378cbbb43ea3f595c890f9d1930b9d054c0813da3f8b1c5509ad2090c78a4d683ed5 SHA512 f913bb116e84c0bd477578e75e10b67ef9c42bb447c2afdeefd9bb8ae291e53b019937d6e474e749a9bf98741366c8e76e5a8dcd23f8a9fac48e306e8dc9a648
DIST intel-compute-runtime-21.43.21438.tar.gz 4840204 BLAKE2B 6de3075132b9a48e97e30e66c6e09dd24f51cabddf55622f2c7490d38bd1ad25e4853206a0a8a3c4c34ac3eb774e44974c47089182652ae2d234044b72d1d048 SHA512 e8f98d9c8c0a01794d57276706ec4212a3fb082c8ac04dc76ceb0e30fecbd8d35405baaa45685fd4b241e8b04a15db16aef75bf1929c81ff879af46e5be00d1e
+DIST intel-compute-runtime-21.44.21506.tar.gz 4851449 BLAKE2B beb49e8bbbfab098bb07943def326463b50f3a4b659368c5b24aadede582331c2c15d4d047e3bbae3d0ca32752c4a05861b0c0a325f30e91bc865276722116b6 SHA512 ae8ca2780602c53f13379ea798462fff1c136967186da21c5b714ed5ab405cb815e0e5e9e60cf8586cef151424270db624b473748d2756ee5768dba4cc020ea6
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-21.44.21506.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.44.21506.ebuild
new file mode 100644
index 000000000000..aa334bc43b1f
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.44.21506.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND="
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.8744
+ >=dev-util/intel-graphics-system-controller-0.2.4
+ >=media-libs/gmmlib-21.2.1
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.5.4 )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+# for Khronos OpenGL headers
+DEPEND="
+ ${RDEPEND}
+ media-libs/mesa
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-21.31.20514-no_Werror.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="ON"
+ )
+
+ cmake_src_configure
+}