summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-01 20:59:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-01 22:01:22 +0100
commit862f6a521f13032878a91ade3a8b8b9bf8745f5f (patch)
tree06c8121b7222c6c1c60bd69a89d84644bf85ecbd
parentdev-qt/qtimageformats: add 5.15.12 (diff)
downloadgentoo-862f6a521f13032878a91ade3a8b8b9bf8745f5f.tar.gz
gentoo-862f6a521f13032878a91ade3a8b8b9bf8745f5f.tar.bz2
gentoo-862f6a521f13032878a91ade3a8b8b9bf8745f5f.zip
dev-qt/qtlocation: add 5.15.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtlocation/Manifest2
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.12.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 3f7965e3dcb5..1a64a1abde23 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,4 +1,6 @@
DIST qtlocation-5.15.11-patchset.tar.xz 4796 BLAKE2B dcfa75bd3fb2e9069e1a530c27e2b4e9ac921fcf0ccb712f0894375b575ba25103948c6e5b85b56a8f9c9f2d7edf7df8e38501e93356e69f060b577a04c2d221 SHA512 14bd2864abc6f446dc4fbac03548cb42305685b46db757d856360780144095a021130bc0ebf1d07a516dc7991dc0cfbf733bd0ef6be58237bc15822c21af1d0b
DIST qtlocation-everywhere-opensource-src-5.15.11.tar.xz 6554216 BLAKE2B e882ecdc4f565f48874371e5235dc96769fbded9446a2a7f1afd869217f4bc75a9f42c6c34627311b55fbfc60da9a95fc7472c3ced83fca722799497b437a9d9 SHA512 d439d03ff9044fc70165d1ceb5def9ec3290beec56b3e893409a24cd355651a4317e0eadff0266d38203ff84429a5fb8659a200f094669716579b6791a1a0f6d
+DIST qtlocation-everywhere-opensource-src-5.15.12.tar.xz 6553488 BLAKE2B e9cab8e6f62cc1cfc6586fa4a1b252bce915479fca5f9fbeac66a2494d77047af4af1ba840786799637edae3af7c6d2000f640af018548cfcd7bd624c6a31b15 SHA512 c480762cea2cd1a00e6061bab05c402d5aab2d12e7decebcd606c930d2029a93f2a46f8edbb188b73c7cdcad473b03c15037ea10e0b3538de0a99b1d7d7fb333
DIST qtlocation-everywhere-src-6.6.1.tar.xz 3035980 BLAKE2B 0221f1d44ff5f0713b93e319989e46af8aaa29178bc8b77081c940c3f7d341701301ac6453f91b2febdcbb67d807ad440eedbd79e5cec5f1ec593ee0f5cef92c SHA512 aa820e84efe3576bf483cd7d64a3b930f731c88324d34cc1486312c1cb0107a726dea91dc226562f017695300f0d656228d947d97374747c3ac6ae597cda6bb5
DIST qtlocation-mapboxgl-5.15.11-4c88f2c0.tar.gz 3726387 BLAKE2B e9b818505ace86516262d1407450c14be82122bb91363a57708795844089371ac7d511a857f713c7cb4e6f8b54867aab0bc5dcdb9c49aa28aa3f8363271378e0 SHA512 e4d9133db892fd8b7b1bcf584bf7dae30c0f0353f3b0a696a6cabc9485067f262d42554b583640521734498572e5480b5e8d0143d5be47bb92077f3192fefa4d
+DIST qtlocation-mapboxgl-5.15.12-4c88f2c0.tar.gz 3726387 BLAKE2B e9b818505ace86516262d1407450c14be82122bb91363a57708795844089371ac7d511a857f713c7cb4e6f8b54867aab0bc5dcdb9c49aa28aa3f8363271378e0 SHA512 e4d9133db892fd8b7b1bcf584bf7dae30c0f0353f3b0a696a6cabc9485067f262d42554b583640521734498572e5480b5e8d0143d5be47bb92077f3192fefa4d
diff --git a/dev-qt/qtlocation/qtlocation-5.15.12.ebuild b/dev-qt/qtlocation/qtlocation-5.15.12.ebuild
new file mode 100644
index 000000000000..b756cb585279
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.12.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PATCHSET="${PN}-5.15.11-patchset"
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ MAPBOXGL_COMMIT=4c88f2c0e61daa89f584a8a9a3eba210221c6920
+ SRC_URI+=" https://invent.kde.org/qt/qt/${PN}-mapboxgl/-/archive/${MAPBOXGL_COMMIT}/${PN}-mapboxgl-${MAPBOXGL_COMMIT}.tar.gz -> ${PN}-mapboxgl-${PV}-${MAPBOXGL_COMMIT:0:8}.tar.gz
+ https://dev.gentoo.org/~asturm/distfiles/${PATCHSET}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+RDEPEND="
+ dev-libs/icu:=
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtpositioning-${QT5_PV}*[qml]
+ =dev-qt/qtsql-${QT5_PV}*
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ =dev-qt/qtconcurrent-${QT5_PV}*
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+
+PATCHES=( "${WORKDIR}/${PATCHSET}" )
+
+src_prepare() {
+ rm -rf src/3rdparty/mapbox-gl-native/* || die
+ mv "${WORKDIR}"/${PN}-mapboxgl-${MAPBOXGL_COMMIT}/* src/3rdparty/mapbox-gl-native || die
+ qt5-build_src_prepare
+}
+fi
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ qt5_configure_oos_quirk qtlocation-config.pri src/location
+ qt5-build_src_configure
+}