summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-07 13:46:51 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-07 13:46:51 +0100
commit8631f1daa61b0769553cee7fe83e6ce7f484b538 (patch)
treeb0067fd5fbd2c5c99e077f5fd1e6935b075f4ca1
parentapp-text/kramdown-rfc: drop 1.6.11, 1.6.13 (diff)
downloadgentoo-8631f1da.tar.gz
gentoo-8631f1da.tar.bz2
gentoo-8631f1da.zip
dev-python/psycopg: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/psycopg/Manifest1
-rw-r--r--dev-python/psycopg/psycopg-2.9.3.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index 51034759daf2..8832b8ca098a 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -1,4 +1,3 @@
DIST psycopg-3.1.3.gh.tar.gz 468400 BLAKE2B 5df0414d1afef4a09a319453e2d9cebd6177af507c30e69aac64dc1d476cf7a0d182c72b81e46d95e3167ee503fa9756ba82ad1092419eea0d6fc3c6e9ba972c SHA512 83ca6dc81cff841c9e22ad8ae86500be0012ee0edbc50b8ab97dcdcbe9d17a8b32feb637275bbaef8333f252aeb961fc5f1f9d2c66dcb1e92b0a1b67223624fb
DIST psycopg-3.1.4.gh.tar.gz 469317 BLAKE2B a6df49a5adefbeb310602473e950ef77f0c613d8a33d41ee37dbfec544dfd014dba8dae5f78ce2bc89f2d9531ccbdd6ea07665ca638f29a4a7d0d1006bc0d778 SHA512 2bf49d6eb7e20c6f22adf47cef6dce691f38f4b310f2fbf3986f3ad14c7d390d53b9edeb3365bbf096941cc2d2affe2ddd542fe93ef37c41109742c9f9af4ba7
-DIST psycopg2-2.9.3.tar.gz 380611 BLAKE2B 78099da7378dcfa8b7f28aae4d533a7e890cdb7ae4c0cc718a9411e630fd07b56f074760fc29de8fe08fe727328cca39414a5f297fb92ed2f7471a24e633d18d SHA512 048184d1d162a371fc0fba711448a6fa8a6aac193421f4484c7f7b91c39065d5b632fa34fc15a901eca055d597302b1f9e38330b248ed0e4653dcdc544b0d660
DIST psycopg2-2.9.4.tar.gz 384017 BLAKE2B 4bc0afcc890c8a257c1ccd5c6e4e5301857a80f8b1428aa46c1473c9e18f5d2914a2e592c13336b06106217bb334d9b0321835bdd123f1627cbeb29dedf97bf7 SHA512 259088e42e0ab0d8a1a0ccf04f5e560f32c6179b4a0a0059e91bcf269baa8f4b0f1f949c332c640a2438c927a29b2c144078a861f8e18ba9c764da7c93c73b8d
diff --git a/dev-python/psycopg/psycopg-2.9.3.ebuild b/dev-python/psycopg/psycopg-2.9.3.ebuild
deleted file mode 100644
index 1f51cddf6b8b..000000000000
--- a/dev-python/psycopg/psycopg-2.9.3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-MY_PN="${PN}2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="PostgreSQL database adapter for Python"
-HOMEPAGE="https://www.psycopg.org https://pypi.org/project/psycopg2/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="LGPL-3+"
-SLOT="2"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="debug test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-db/postgresql-8.1:*"
-DEPEND="${RDEPEND}"
-BDEPEND="
- test? ( >=dev-db/postgresql-8.1[server] )"
-
-python_prepare_all() {
- if use debug; then
- sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- initdb -D "${T}"/pgsql || die
- # TODO: random port
- pg_ctl -w -D "${T}"/pgsql start \
- -o "-h '' -k '${T}'" || die
- createdb -h "${T}" psycopg2_test || die
-
- local -x PSYCOPG2_TESTDB_HOST="${T}"
- distutils-r1_src_test
-
- pg_ctl -w -D "${T}"/pgsql stop || die
-}
-
-python_test() {
- "${EPYTHON}" -c "
-import tests
-tests.unittest.main(defaultTest='tests.test_suite')
-" --verbose || die "Tests fail with ${EPYTHON}"
-}