summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-01 12:05:00 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-01 12:05:00 +0100
commit86600fb43e4b71204bb4847c6709d7e5e2890577 (patch)
tree8da7754ad45a5fa6a2b3c3af21feb23db1b0a2b1
parentdev-python/openpyxl: Add doc-dep on sphinx_rtd_theme (diff)
downloadgentoo-86600fb43e4b71204bb4847c6709d7e5e2890577.tar.gz
gentoo-86600fb43e4b71204bb4847c6709d7e5e2890577.tar.bz2
gentoo-86600fb43e4b71204bb4847c6709d7e5e2890577.zip
app-vim/gentoo-syntax: Bump to v6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 61325d895520..1328f77d40f2 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,2 +1,3 @@
DIST gentoo-syntax-4.tar.bz2 20344 BLAKE2B 3e9b75c1e9e395e04547a95bb6abd17e7404389ccc5a47d9cf9ca2973a55666ce17607c72fbd15a9b167033bf0f7d1447817b9346d56e2ddbd48c2acbdfdcffa SHA512 4aec2c40c4f582f697cc11ac73fe9301ce25bb38f240cc3c9e426247a4bd38fb83aa05407b65ac68313793735eafc71a3b1b55e0db4301941afe7c720a51bc85
DIST gentoo-syntax-5.tar.bz2 20386 BLAKE2B 8f5ba5bdf4a5caff400d4af0f0e88b2bfe36ab550a4cb6045dd2c2b00a00fc3a95fd6394eabf0316fb36bdb454c774fd3a4e86818230bbab5c54996c29fae581 SHA512 e57d0b9eeff27ce591ce3f6a759b18f08a272e44d59063dd34a6543ce909e03509c8503f92d8c67aba092944e549ff43672c3ebc9f97100e84abeba4a7a322f6
+DIST gentoo-syntax-6.tar.bz2 21077 BLAKE2B 76d3cfff7eb8c6ea393770126eef8a39df010292edd95bf2599e0a341cd4d7399b17c27a1d3dfdc420268c9c3f14b8cd477b325c7b9525c547c5ae1b864061c3 SHA512 97792795d42f3fdb42bf8d1d2b531e47bbed463f14d2acdb1e801b96c980829dfd2a858f7b46d48892152b36f22ec0e478f6bb7ee374cdd3c69d7316641aa307
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-6.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-6.ebuild
new file mode 100644
index 000000000000..c560022b6db4
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}