summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-30 22:01:09 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-31 00:09:27 +0100
commit866dccad5ccdc664776e55918e9e968fd3c2ff6c (patch)
tree6e54e718d19eb39cba9ed3884e03a40a09fc80a5
parentapp-emacs/mastodon: bump to 1.0.19 (diff)
downloadgentoo-866dccad5ccdc664776e55918e9e968fd3c2ff6c.tar.gz
gentoo-866dccad5ccdc664776e55918e9e968fd3c2ff6c.tar.bz2
gentoo-866dccad5ccdc664776e55918e9e968fd3c2ff6c.zip
app-emacs/mastodon: sync live 9999 version
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/mastodon/mastodon-1.0.18.ebuild1
-rw-r--r--app-emacs/mastodon/mastodon-1.0.19.ebuild1
-rw-r--r--app-emacs/mastodon/mastodon-9999.ebuild39
3 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/mastodon/mastodon-1.0.18.ebuild b/app-emacs/mastodon/mastodon-1.0.18.ebuild
index 38f5552d3c9f..2a79521adfed 100644
--- a/app-emacs/mastodon/mastodon-1.0.18.ebuild
+++ b/app-emacs/mastodon/mastodon-1.0.18.ebuild
@@ -14,6 +14,7 @@ if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://codeberg.org/martianh/mastodon.el.git"
+ S="${WORKDIR}/${P}/lisp"
else
SRC_URI="https://codeberg.org/martianh/${PN}.el/archive/${PV}.tar.gz
-> ${P}.tar.gz"
diff --git a/app-emacs/mastodon/mastodon-1.0.19.ebuild b/app-emacs/mastodon/mastodon-1.0.19.ebuild
index 38f5552d3c9f..2a79521adfed 100644
--- a/app-emacs/mastodon/mastodon-1.0.19.ebuild
+++ b/app-emacs/mastodon/mastodon-1.0.19.ebuild
@@ -14,6 +14,7 @@ if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://codeberg.org/martianh/mastodon.el.git"
+ S="${WORKDIR}/${P}/lisp"
else
SRC_URI="https://codeberg.org/martianh/${PN}.el/archive/${PV}.tar.gz
-> ${P}.tar.gz"
diff --git a/app-emacs/mastodon/mastodon-9999.ebuild b/app-emacs/mastodon/mastodon-9999.ebuild
new file mode 100644
index 000000000000..2a79521adfed
--- /dev/null
+++ b/app-emacs/mastodon/mastodon-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs client for Mastodon, federated microblogging social network"
+HOMEPAGE="https://codeberg.org/martianh/mastodon.el/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://codeberg.org/martianh/mastodon.el.git"
+ S="${WORKDIR}/${P}/lisp"
+else
+ SRC_URI="https://codeberg.org/martianh/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}.el/lisp"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/persist
+ app-emacs/request
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( ../README.org )
+ELISP_TEXINFO="../${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"