summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-12-29 14:15:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-12-29 14:15:54 +0100
commit8676ed83a71475247f285afc588efe0c483c7e80 (patch)
treee65c87834eab4251da56cc54e433f40d14b8fbb2
parentdev-perl/CGI-FormBuilder: Remove old (diff)
downloadgentoo-8676ed83.tar.gz
gentoo-8676ed83.tar.bz2
gentoo-8676ed83.zip
media-libs/libyami: bump to 0.3.1
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--media-libs/libyami/Manifest1
-rw-r--r--media-libs/libyami/libyami-0.3.1.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/media-libs/libyami/Manifest b/media-libs/libyami/Manifest
index cdd7bb9a6a02..03208c8adccb 100644
--- a/media-libs/libyami/Manifest
+++ b/media-libs/libyami/Manifest
@@ -1 +1,2 @@
DIST libyami-0.3.0.tar.gz 484586 SHA256 67064558999d63185025a6d63d08458375003bb86369abca50aca97fd2c63acb SHA512 691cbe90840d8cb30da958bb6621434c9962ae6cbfc75b016454570c303a01e7a465baa8622368cf1ef1c670dbc861fb1d49e0c414d684feae04ea742e8e0599 WHIRLPOOL d842f1ce57d40894b80f868934d687603014b6460bdbd274b64893d8f290f8a6a779239f931beb759a7fb8e5ed1649b90fb545391c1d9c8395bb05f6600218d2
+DIST libyami-0.3.1.tar.gz 492223 SHA256 7ab680138a1d34eb306bc941198f0715631bc8e5b0ee5717b3171f6672ca3bcb SHA512 eb58a6925de8379e40b2482780340becdb8c9295041bba11bf439cc2ff19c25f10ce4b1fc2b6c421342855946ddd471745bdfb364a227499658867911325b375 WHIRLPOOL ce44614aa04127c828761319dd96ee35956daea9cf7577e7631083e10db744c76596da7135f8f6c16952639c601ee065afe8c0097bf6d23829dc9893c4aa414f
diff --git a/media-libs/libyami/libyami-0.3.1.ebuild b/media-libs/libyami/libyami-0.3.1.ebuild
new file mode 100644
index 000000000000..3951d2f79326
--- /dev/null
+++ b/media-libs/libyami/libyami-0.3.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM=git-r3
+ EGIT_REPO_URI="https://github.com/01org/libyami"
+fi
+
+inherit ${SCM} autotools multilib-minimal
+
+DESCRIPTION="Yet Another Media Infrastructure: Media codec with hardware acceleration"
+HOMEPAGE="https://github.com/01org/libyami"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/01org/libyami/archive/${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="+capi debug dmabuf doc ffmpeg gles +glx libav md5 tools v4l X"
+
+RDEPEND="
+ >=x11-libs/libva-1.6[drm,X?,${MULTILIB_USEDEP}]
+ v4l? (
+ glx? (
+ >=x11-libs/libva-1.6[X,${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=virtual/opengl-7[${MULTILIB_USEDEP}]
+ )
+ !glx? ( >=media-libs/mesa-10[egl,${MULTILIB_USEDEP}] )
+ >=media-libs/libv4l-1.6.2[${MULTILIB_USEDEP}]
+ )
+ X? ( >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}] )
+ ffmpeg? (
+ !libav? ( media-video/ffmpeg:0=[${MULTILIB_USEDEP}] )
+ libav? ( media-video/libav:=[${MULTILIB_USEDEP}] )
+ )
+ md5? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ dmabuf? ( x11-libs/libdrm[${MULTILIB_USEDEP}] )
+ tools? (
+ gles? ( >=media-libs/mesa-10[egl,gles2,${MULTILIB_USEDEP}] )
+ v4l? ( !glx? ( >=media-libs/mesa-10[egl,gles2,${MULTILIB_USEDEP}] ) )
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable debug) \
+ $(multilib_native_use_enable tools tests) \
+ $(use gles && multilib_native_use_enable tools tests-gles) \
+ $(use_enable v4l v4l2) \
+ $(usex v4l $(use_enable glx v4l2-glx) "--disable-v4l2-glx") \
+ $(use_enable capi) \
+ $(use_enable X x11) \
+ $(use_enable dmabuf) \
+ $(use_enable ffmpeg avformat) \
+ $(use_enable md5) \
+ $(multilib_native_use_enable doc docs) \
+ --enable-vp8dec \
+ --enable-vp9dec \
+ --enable-jpegdec \
+ --enable-h264dec \
+ --disable-h265dec \
+ --enable-h264enc \
+ --enable-jpegenc \
+ --enable-vp8enc \
+ --enable-h265enc
+
+ # h265 decoder doesnt build here with gcc 5.2
+}
+
+multilib_src_compile() {
+ emake
+ multilib_is_native_abi && use doc && emake -C doc
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ multilib_is_native_abi && use doc && dohtml -r doc/html/*
+}
+
+src_install() {
+ multilib-minimal_src_install
+ find "${ED}" -name '*.la' -delete
+}