summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-12-28 09:13:00 +0100
committerHans de Graaff <graaff@gentoo.org>2018-12-28 12:12:47 +0100
commit867df861d2094b9b3a37a52923c8c4ffa549893f (patch)
treebfddd91ae5dad5abd6189a47bbd4533904dc91ff
parentgnome-extra/libgda: require openssl-1.0*, add glib-utils dep (diff)
downloadgentoo-867df861.tar.gz
gentoo-867df861.tar.bz2
gentoo-867df861.zip
dev-ruby/coderay: add ruby26
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-ruby/coderay/coderay-1.1.2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-ruby/coderay/coderay-1.1.2.ebuild b/dev-ruby/coderay/coderay-1.1.2.ebuild
index e1597c0c0602..5e141439e49c 100644
--- a/dev-ruby/coderay/coderay-1.1.2.ebuild
+++ b/dev-ruby/coderay/coderay-1.1.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
# The test target also contains test:exe but that requires
# shoulda-context which we do not have packaged yet.
@@ -33,4 +33,7 @@ IUSE=""
all_ruby_prepare() {
sed -i -e "/[Bb]undler/d" Rakefile || die
sed -i -e '/git ls-files/ s:^:#:' coderay.gemspec || die
+
+ # Fix failing tests for lazy evaluation in ruby26
+ sed -i -e 's/\.filter$/.filter.to_a/' test/unit/filter.rb || die
}