summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-30 00:55:56 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-30 01:15:59 +0100
commit868519986192e956b7959ac346395fd755a8cb8d (patch)
tree1cf0ea18eaf6a67ea8e867c9e3dc28521ccc25c8
parentsys-libs/musl: 1.2.1-r1 stable on x86 (diff)
downloadgentoo-86851998.tar.gz
gentoo-86851998.tar.bz2
gentoo-86851998.zip
dev-lua/busted-htest: new package
This is a module for dev-lua/busted called htest. It adds a different output, which is used by the tests of dev-lua/luarocks. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/busted-htest/Manifest1
-rw-r--r--dev-lua/busted-htest/busted-htest-1.0.0-r100.ebuild34
-rw-r--r--dev-lua/busted-htest/busted-htest-1.0.0.ebuild30
-rw-r--r--dev-lua/busted-htest/metadata.xml11
-rw-r--r--profiles/package.mask1
5 files changed, 77 insertions, 0 deletions
diff --git a/dev-lua/busted-htest/Manifest b/dev-lua/busted-htest/Manifest
new file mode 100644
index 000000000000..2c720b589812
--- /dev/null
+++ b/dev-lua/busted-htest/Manifest
@@ -0,0 +1 @@
+DIST busted-htest-1.0.0.tar.gz 4347 BLAKE2B f1d30a305cb9691588b18f67842b536d3de9430d22c51ec292202e5aca5784447cd525ae8b1f1da42a3d3792344419efbfe1d03fe29823b445a7c1ead0fe577f SHA512 001f494949c04445004e8b06fde62727cab85a320673748d18714b82d7b2b9aea43316f6119e669c569f31578b787f4e5ca5d19da3f33fe28df572aaa41c75bd
diff --git a/dev-lua/busted-htest/busted-htest-1.0.0-r100.ebuild b/dev-lua/busted-htest/busted-htest-1.0.0-r100.ebuild
new file mode 100644
index 000000000000..8cd1f8a95c7b
--- /dev/null
+++ b/dev-lua/busted-htest/busted-htest-1.0.0-r100.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+
+inherit lua
+
+DESCRIPTION="Pretty output handler for Busted"
+HOMEPAGE="https://github.com/hishamhm/busted-htest"
+SRC_URI="https://github.com/hishamhm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-lua/busted-2.0.0-r100[${LUA_USEDEP}]
+ ${LUA_DEPS}
+"
+
+BDEPEND="virtual/pkgconfig"
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins src/busted/outputHandlers/htest.lua
+
+ einstalldocs
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}
diff --git a/dev-lua/busted-htest/busted-htest-1.0.0.ebuild b/dev-lua/busted-htest/busted-htest-1.0.0.ebuild
new file mode 100644
index 000000000000..7007e6d3c37a
--- /dev/null
+++ b/dev-lua/busted-htest/busted-htest-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Pretty output handler for Busted"
+HOMEPAGE="https://github.com/hishamhm/busted-htest"
+SRC_URI="https://github.com/hishamhm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="luajit"
+
+RDEPEND="
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? ( >=dev-lang/lua-5.1:0 )
+ dev-lua/busted
+"
+
+BDEPEND="virtual/pkgconfig"
+
+src_install() {
+ insinto $($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))
+ doins src/busted/outputHandlers/htest.lua
+
+ einstalldocs
+}
diff --git a/dev-lua/busted-htest/metadata.xml b/dev-lua/busted-htest/metadata.xml
new file mode 100644
index 000000000000..d43b8f09772a
--- /dev/null
+++ b/dev-lua/busted-htest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hishamhm/busted-htest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 219353df6750..470f230eddef 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -516,6 +516,7 @@ dev-lua/luacrypto
=dev-games/openscenegraph-openmw-3.4_p20200425-r100
=dev-libs/efl-1.25.1-r10
>=dev-lua/busted-2.0.0-r100
+>=dev-lua/busted-htest-1.0.0-r100
>=dev-lua/dkjson-2.5-r100
>=dev-lua/ldoc-1.4.6-r100
>=dev-lua/lgi-0.9.2-r100