summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-11 17:41:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-11 17:46:40 +0200
commit868d8b71db3e022ec2e5813ba50e0491efe40690 (patch)
treee4ddab9ed3452da773bb042703ce8f4fda6d9794
parentdev-ros/python_cmake_module: initial import (diff)
downloadgentoo-868d8b71db3e022ec2e5813ba50e0491efe40690.tar.gz
gentoo-868d8b71db3e022ec2e5813ba50e0491efe40690.tar.bz2
gentoo-868d8b71db3e022ec2e5813ba50e0491efe40690.zip
dev-python/osrf_pycommon: initial import
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-python/osrf_pycommon/Manifest1
-rw-r--r--dev-python/osrf_pycommon/files/str.patch23
-rw-r--r--dev-python/osrf_pycommon/metadata.xml11
-rw-r--r--dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild24
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/osrf_pycommon/Manifest b/dev-python/osrf_pycommon/Manifest
new file mode 100644
index 000000000000..c66df3e411e8
--- /dev/null
+++ b/dev-python/osrf_pycommon/Manifest
@@ -0,0 +1 @@
+DIST osrf_pycommon-0.1.10.tar.gz 46303 BLAKE2B 3f18b8683a6363e1f15addfe75b8dee31f64fff7c286379d18355dc1f3467063c2cf1a9eb7978c5f9de5d64cb23d18a3922a416fe24fafa618f50f0ba89cddfe SHA512 5d53ea0c3c410a99964330dc22dcbcb3cd8892a359fee2061acc15ddb46e334ff757e8aa5b776fef381246c58e9834003ac818624da4b8e95552f214f3d9e6bb
diff --git a/dev-python/osrf_pycommon/files/str.patch b/dev-python/osrf_pycommon/files/str.patch
new file mode 100644
index 000000000000..336813e416fa
--- /dev/null
+++ b/dev-python/osrf_pycommon/files/str.patch
@@ -0,0 +1,23 @@
+From 515fd938513b8e458ce5fb3c937c100a3bc87745 Mon Sep 17 00:00:00 2001
+From: Chris Lalancette <clalancette@openrobotics.org>
+Date: Fri, 19 Jun 2020 17:48:05 -0400
+Subject: [PATCH] Fix the __str__ method for windows terminal_color. (#65)
+
+Signed-off-by: Chris Lalancette <clalancette@openrobotics.org>
+---
+ osrf_pycommon/terminal_color/windows.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/osrf_pycommon/terminal_color/windows.py b/osrf_pycommon/terminal_color/windows.py
+index f0f6120..21f5e8f 100644
+--- a/osrf_pycommon/terminal_color/windows.py
++++ b/osrf_pycommon/terminal_color/windows.py
+@@ -224,7 +224,7 @@ class CONSOLE_SCREEN_BUFFER_INFO(ctypes.Structure):
+
+ def __str__(self):
+ return (
+- '({0}, {0}, {0}, {0}, {0}, {0}, {0}, {0}, {0}, {0}, {0})'
++ '({0}, {1}, {2}, {3}, {4}, {5}, {6}, {7}, {8}, {9}, {10})'
+ .format(
+ self.dwSize.Y, self.dwSize.X,
+ self.dwCursorPosition.Y, self.dwCursorPosition.X,
diff --git a/dev-python/osrf_pycommon/metadata.xml b/dev-python/osrf_pycommon/metadata.xml
new file mode 100644
index 000000000000..b48cc9c2c50e
--- /dev/null
+++ b/dev-python/osrf_pycommon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">osrf/osrf_pycommon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild b/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild
new file mode 100644
index 000000000000..5766d731686f
--- /dev/null
+++ b/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Commonly needed Python modules used by Python software developed at OSRF"
+HOMEPAGE="https://github.com/osrf/osrf_pycommon"
+SRC_URI="https://github.com/osrf/osrf_pycommon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RESTRICT=""
+
+DEPEND="dev-python/mock[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+PATCHES=( "${FILESDIR}/str.patch" )
+
+distutils_enable_tests pytest