summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-08-04 08:33:00 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-08-04 08:33:10 +0200
commit869af7e91d35f16813aa313b96b59f14acf1d8c9 (patch)
treee45bc8abcaceeb48ae61e0fe0ef9f69ae2c581dd
parentdev-java/maven-bin: bump to 3.9.4 (diff)
downloadgentoo-869af7e91d35f16813aa313b96b59f14acf1d8c9.tar.gz
gentoo-869af7e91d35f16813aa313b96b59f14acf1d8c9.tar.bz2
gentoo-869af7e91d35f16813aa313b96b59f14acf1d8c9.zip
media-sound/exaile: bump to 4.1.3
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/exaile/Manifest1
-rw-r--r--media-sound/exaile/exaile-4.1.3.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/media-sound/exaile/Manifest b/media-sound/exaile/Manifest
index 4ea8546ade82..801abb1d2ed7 100644
--- a/media-sound/exaile/Manifest
+++ b/media-sound/exaile/Manifest
@@ -1 +1,2 @@
DIST exaile-4.1.2.tar.gz 3708188 BLAKE2B 859d77bac62df0843291fdc0de4888079c8f103da3cdf3417d0cd5ba67cf5199a8a1e89d20403efbc6793dfcd7b8333708df74ff535e0912fb02502a13702a0a SHA512 7711f9e062088b02362bbd404f7c61a0f1c128e29e42ce657dc092cac351641f6000846c9da843866bf28ccbd68cf1b07731ba1c9854d52b33c0448e87d0e93b
+DIST exaile-4.1.3.tar.gz 3853508 BLAKE2B 3ce7bbd84dda419b817f0684b2279e29a48b7c221eb3d335f3b3797be4dbbec9158b576337084cdd0d242d79fdf14616c1e0b8b171e3995689f94945aa7385b6 SHA512 16b31331a31f0a2e088f177c8a01ef47603b07fe94cbb19869a4caeaec2da03cacaa07d5b0eb50052645449e07620e2c58f202007108af73e20cf744d70bb556
diff --git a/media-sound/exaile/exaile-4.1.3.ebuild b/media-sound/exaile/exaile-4.1.3.ebuild
new file mode 100644
index 000000000000..3c7be5deff10
--- /dev/null
+++ b/media-sound/exaile/exaile-4.1.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-single-r1 xdg
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/exaile/exaile.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV/_/-}/${PN}-${PV/_/}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+fi
+
+DESCRIPTION="GTK+ based media player aiming to be similar to Amarok"
+HOMEPAGE="https://www.exaile.org/"
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+# IUSE+=cddb if have dev-python/cddb-py
+IUSE="libnotify nls scrobbler"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+RDEPEND="${PYTHON_DEPS}
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0
+ x11-libs/gtk+:3[introspection]
+ libnotify? ( x11-libs/libnotify[introspection] )
+ $(python_gen_cond_dep '
+ dev-python/bsddb3[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ scrobbler? ( dev-python/pylast[${PYTHON_USEDEP}] )
+ ')
+"
+
+RESTRICT="test" #315589
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_compile() {
+ use nls && emake locale
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ LIBINSTALLDIR=/usr/$(get_libdir) \
+ DESTDIR="${D}" \
+ install$(use nls || echo _no_locale)
+
+ python_optimize "${D}/usr/$(get_libdir)/${PN}"
+ python_optimize "${D}/usr/share/${PN}"
+}