summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-17 06:44:25 +0000
committerSam James <sam@gentoo.org>2022-05-17 06:45:49 +0000
commit86a0bcad235a50769229075c60b15f410d9dba50 (patch)
tree7b478d9a06a44a34d2ed4c3e27c3867d0f719b0f
parentdev-libs/sleef: add to tree (diff)
downloadgentoo-86a0bcad.tar.gz
gentoo-86a0bcad.tar.bz2
gentoo-86a0bcad.zip
app-arch/bzip2: run test suite
The Makefile in the builddir lacks a check target so we'd silently skip it before. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-arch/bzip2/bzip2-1.0.8-r1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/app-arch/bzip2/bzip2-1.0.8-r1.ebuild b/app-arch/bzip2/bzip2-1.0.8-r1.ebuild
index a3ee12f8c36c..62a13959bff9 100644
--- a/app-arch/bzip2/bzip2-1.0.8-r1.ebuild
+++ b/app-arch/bzip2/bzip2-1.0.8-r1.ebuild
@@ -67,6 +67,11 @@ multilib_src_compile() {
bemake -f "${S}"/Makefile all LDFLAGS="${LDFLAGS} $(usex static -static '')"
}
+multilib_src_test() {
+ cp "${S}"/sample* "${BUILD_DIR}" || die
+ bemake -f "${S}"/Makefile check
+}
+
multilib_src_install() {
into /usr