summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-15 07:03:20 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-15 08:02:54 +0100
commit86aa25e18f6237ed1aa8db59cca65bb549c8495c (patch)
treebf9d28de165582cba43dcd0901ebfb6223b9a07c
parentdev-python/pytest: Bump to 7.2.1 (diff)
downloadgentoo-86aa25e1.tar.gz
gentoo-86aa25e1.tar.bz2
gentoo-86aa25e1.zip
dev-python/rich: Bump to 13.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-13.1.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 75108e1b956b..20483eab9fb6 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,3 +1,4 @@
DIST rich-12.6.0.gh.tar.gz 15056457 BLAKE2B 58367ef0acb61d68931ea0394ea458e29b3bb59726c6b95d4b179553183c5cef2766484e0d040203181aad927add70198fb3483bfe6113e20851db141de3a867 SHA512 e05a0ad1d6b4f1e4f7e5e3d09c70d5892a618707ae0952e34274c5ffb18a833fe85a4ac15024cc34915515b63059c02f0df32a6c97cbe91e9ac96928c7134fb0
DIST rich-13.0.0.gh.tar.gz 15065008 BLAKE2B b2b323b633e6600dd1595c1769daf3659b2d7cf6f98fe91ca9e083c24bc3de9de79b27de08144ab7acaa3634cc588f1548d73536555a06f1b4832f91c978ab9a SHA512 6837aad1015318c0a017000ba60cea0b4b06e85b7fb9650e90ed87ca8dedd3bf3369c5520571661123aee099380445eefa6b30002f0290c2160540a49433bb91
DIST rich-13.0.1.gh.tar.gz 15065056 BLAKE2B 71d6418b483a88834f7fbce9d9ac8deffbf8940b32ac751503b68994ac1717c8cbede57a37fa33ba025ee6f03196a65797f934252c1658e7ca651cef759d731e SHA512 12458ceae7cc1a8796339547405df23598adbf8ac71dec42b65e0685c8725b0f183b4934c9a91690be3f54af463a91645cb595934749c0ee4ac7d1a4062cfb46
+DIST rich-13.1.0.gh.tar.gz 15065402 BLAKE2B 3d23cbf20536e0d1ed9cfa6257875e49d319364f4c9696643f6fbe6da01dd30b1de639b75631fbe6ab1204e177017031bea23f3e0e07b808070068e39397664f SHA512 6a8f264e16f691f38e4094359bad46cc62d40e5118887311d91732a194100aae27da8f2b29ba21b3cf1ec46c42d3b7d4446f125421e5494725bc5095bcc36104
diff --git a/dev-python/rich/rich-13.1.0.ebuild b/dev-python/rich/rich-13.1.0.ebuild
new file mode 100644
index 000000000000..294866c9fd24
--- /dev/null
+++ b/dev-python/rich/rich-13.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ # pygments?
+ tests/test_syntax.py::test_python_render_simple_indent_guides
+ tests/test_syntax.py::test_python_render_line_range_indent_guides
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}