summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-03 22:33:26 -0500
committerSam James <sam@gentoo.org>2024-02-04 20:10:37 +0000
commit86c9b71c77e482ffa75e63c12b4afb2cd8f58caa (patch)
treede2d92e3ca9ef8a95dca5edabedbee562fa6c2c5
parentsci-libs/hdf5: suppress LTO due to compile errors (diff)
downloadgentoo-86c9b71c77e482ffa75e63c12b4afb2cd8f58caa.tar.gz
gentoo-86c9b71c77e482ffa75e63c12b4afb2cd8f58caa.tar.bz2
gentoo-86c9b71c77e482ffa75e63c12b4afb2cd8f58caa.zip
dev-python/packaging: remove outdated runtime dep on pyparsing
In upstream version 22.0 this external dependency was removed in favor of rewriting a custom parser for internal use: https://github.com/pypa/packaging/commit/2e5593c1288b9f1b57bb1f79acc0ed5fd1b7009c Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/packaging/packaging-23.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/packaging/packaging-23.2-r1.ebuild b/dev-python/packaging/packaging-23.2-r1.ebuild
new file mode 100644
index 000000000000..4d07f6ea8577
--- /dev/null
+++ b/dev-python/packaging/packaging-23.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="
+ https://github.com/pypa/packaging/
+ https://pypi.org/project/packaging/
+"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/setuptools-67
+"
+DEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --capture=no
+}