summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-10 09:32:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-10 10:01:50 +0200
commit86cdd780c02d83e5d024af767bbb718df13bd392 (patch)
treeb61bf3701d0d43721df150eb9887274f9f8c46b5
parentdev-python/botocore: Bump to 1.20.49 (diff)
downloadgentoo-86cdd780c02d83e5d024af767bbb718df13bd392.tar.gz
gentoo-86cdd780c02d83e5d024af767bbb718df13bd392.tar.bz2
gentoo-86cdd780c02d83e5d024af767bbb718df13bd392.zip
dev-python/boto3: Bump to 1.17.49
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.49.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index e005828bb6a2..b791b4266557 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -12,3 +12,4 @@ DIST boto3-1.17.45.tar.gz 359297 BLAKE2B 2e0f2b3b13db473f2067d2d662dbe867189f4e8
DIST boto3-1.17.46.tar.gz 359739 BLAKE2B 87c22c4605c521e8b80b5b366cc56ce88745cba3fce12ed8a5dd6905b27fbd67dc440eac05f45552f80b6b281df10265d7dce2ef378840c7d6f7d1f1239e478f SHA512 84eabf10695c3fa236436658b878fa2de5c3307aef9f8b68047c1481963fe479b642cff22852a6f76bd208622da61398cbfc3feb3c5f5f6c03ac9e4e1e06a441
DIST boto3-1.17.47.tar.gz 360120 BLAKE2B 11f29c956d317956fbe84a1bea953350cd69c25bbf03bb3098b811c541cdc81ea5e4f80be81b6442ee3064b76eb9dc97f8e2369d95c4b080fe4efa7ec468c2e9 SHA512 1608c5ddf65097c4f3c48a1544fb55e9d5beeb59d58fb781574cc47ce39b693cc030ac8f21fbababd4253ccebdacf4b4a1df6afb0b02cdb8e0d4a92c28a48c2e
DIST boto3-1.17.48.tar.gz 360582 BLAKE2B 69d377f058865c96e7920fa42c28bababc2f26d8375860f112391dbd8c041370b5d24d64f1a62902f46b0356bf491aba7f3d1b3f53e2ea79c224cfc1d1bb9cc2 SHA512 ebe21d25a0c6a2edcea5e98027d53013b30e5445b4e954ed6d5a684075289b9077e880dedd55f70133111bd0fbd5da9d737c0f15dea157b8d8d45e350cd44cec
+DIST boto3-1.17.49.tar.gz 360898 BLAKE2B 6fa6fddf1f5df4d28ed2163feef1f3e3349c9096a9aaa2d07a9ed0c82c893a40227b8f714fec95bf271622e3243faf6b2f6d087bb0b09094ad99e1ae764c7795 SHA512 ed49d19cc9076828c01665af616d12e7b8466aaccaafb263ee845bec6dc3e49c79a85347c68230358658b39b8ff656b674f8812c69b820bb455b584152ce39d6
diff --git a/dev-python/boto3/boto3-1.17.49.ebuild b/dev-python/boto3/boto3-1.17.49.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.49.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}