summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-29 22:21:01 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-29 22:22:04 +0100
commit86d0e242ae40560010204fe7c5c0d69ce22b3c47 (patch)
tree8ffd00a509fb1b60501bc1aab295fee77b6d00bc
parentapp-emacs/sml-mode: bump to 6.11 (diff)
downloadgentoo-86d0e242.tar.gz
gentoo-86d0e242.tar.bz2
gentoo-86d0e242.zip
app-emacs/slime: bump to 2.28
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/slime/Manifest1
-rw-r--r--app-emacs/slime/slime-2.28.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-emacs/slime/Manifest b/app-emacs/slime/Manifest
index b81896216bc2..02c44abf4c32 100644
--- a/app-emacs/slime/Manifest
+++ b/app-emacs/slime/Manifest
@@ -1 +1,2 @@
DIST slime-2.27.tar.gz 824013 BLAKE2B 65bf6022d4c0df7fd7b3c8325ce0e8db1bd7b39961b88ea3bca846c316db2a6442d87974f9399557e9ea1ac7f10ec32d13832df3f433ab3b38cf3059a9529069 SHA512 e1d4723d62bd6c9cd964bfc5ff2d383999d0c965ba9e0742dd21453e8f660dc5c05b2bb8f009ac895dd7445a77b82b5c1dec19ec195368f8cfa59f651001da6e
+DIST slime-2.28.tar.gz 826876 BLAKE2B 9e93af7a7f9e1ef1aed7b513a0b83f426186582bcd43dabad5fe962afe77803bf237d92e79ccabb93b419a7f678168e89584b4f5bb8423918abcac8915411283 SHA512 4184765048302ac568ddb89bfc0ac9fd3af4f0e3c8c39e81e27e58c9342f48332ac365edfd876e6e69e8e13db137d3e14c84cf4608158c4528bb34b0d7313991
diff --git a/app-emacs/slime/slime-2.28.ebuild b/app-emacs/slime/slime-2.28.ebuild
new file mode 100644
index 000000000000..da4135f52bf4
--- /dev/null
+++ b/app-emacs/slime/slime-2.28.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="SLIME, the Superior Lisp Interaction Mode (Extended)"
+HOMEPAGE="https://slime.common-lisp.dev/"
+SRC_URI="https://github.com/slime/slime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain GPL-2+ GPL-3+ LLGPL-2.1 ZLIB xref? ( xref.lisp )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc xref"
+RESTRICT="test" # tests fail to contact sbcl
+
+RDEPEND="virtual/commonlisp
+ dev-lisp/asdf"
+DEPEND="${RDEPEND}"
+BDEPEND=">=sys-apps/texinfo-5.1
+ doc? ( virtual/texi2dvi )"
+
+SITEFILE="70${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ # Remove xref.lisp (which is non-free) unless USE flag is set
+ use xref || rm xref.lisp || die
+}
+
+src_compile() {
+ elisp-compile *.el
+ BYTECOMPFLAGS="${BYTECOMPFLAGS} -L contrib -l slime" \
+ elisp-compile contrib/*.el lib/*.el
+
+ emake -C doc slime.info
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts emake -C doc all
+ fi
+}
+
+src_install() {
+ # Install core
+ elisp-install ${PN} *.{el,elc,lisp}
+
+ # Install contribs
+ elisp-install ${PN}/contrib/ contrib/*.{el,elc} contrib/swank*
+
+ # Install lib
+ elisp-install ${PN}/lib/ lib/*.{el,elc}
+
+ # Install swank
+ elisp-install ${PN}/swank/ swank/*.lisp
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ # Install docs
+ dodoc README.md CONTRIBUTING.md NEWS PROBLEMS
+ newdoc contrib/README.md README-contrib.md
+ doinfo doc/slime.info
+ use doc && dodoc doc/*.pdf
+
+ # Bug #656760
+ touch "${ED}${SITELISP}/${PN}/lib/.nosearch" || die
+}