summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2023-10-21 02:45:58 +0000
committerYixun Lan <dlan@gentoo.org>2023-11-01 06:35:40 +0000
commit86dd6741739d52f7a849a496695b5dadbd4f94ba (patch)
tree083201beb8c60eb4b3cabd6d9a50287bb57e2127
parentwww-apps/gitea: add 1.20.5 (diff)
downloadgentoo-86dd6741739d52f7a849a496695b5dadbd4f94ba.tar.gz
gentoo-86dd6741739d52f7a849a496695b5dadbd4f94ba.tar.bz2
gentoo-86dd6741739d52f7a849a496695b5dadbd4f94ba.zip
www-apps/gitea: drop old
Closes: https://github.com/gentoo/gentoo/pull/33435 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.19.3.ebuild114
2 files changed, 0 insertions, 115 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index b710feb0e943..137351b79864 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,3 +1,2 @@
-DIST gitea-1.19.3.tar.gz 55634848 BLAKE2B 6d33b7d47039f0e34578d0c0e74d4ec77e485e9a1977ba81295fb1b8b10e103a4801530145d71aa97dba69ea115752f027c79c2f70022a65c35d4119a4553a77 SHA512 e77372f2354d433f7703d49c3d30238bad3ad6cd0722d4e0fa374692a8a0d6314bb8327807ec2b992ec84de420e09d48aaa3af16ad37b0ee0beb5540f395688f
DIST gitea-1.20.4.tar.gz 50489949 BLAKE2B 1c14ec9f784cbbe3f67872b5344df209009bd32dc624b8e0351c2050ffa90657556ec6bd77b69acdb7a7506918aafbbb72a97839d92c2b39241c308ebeb4e565 SHA512 5e08959e0ff421898aebcb7640ab0869c1cabd82c84254c94024d2da16f91755e183b477a190a7b1987a5ab9ae7787c85d37fb9db990bddda937a4200777ed7c
DIST gitea-1.20.5.tar.gz 50448780 BLAKE2B d8a1dc6bc147a06adc9280ea5d75d8cf039d447d96b4cd4ca6b35b11af5ed71df73d36b4c102f5b8ded2ba85efaea6104b31a4f39ab66c8a0c98cd36e826b734 SHA512 360a7a7bf0a51ea6d1fbcdfb35c5c3492b4fc6e29a9b60d0e6c6d01257d4743c580cf907293df8a4244750c5afe9ba1b33b2a898a18dd9e13947c58116ba3021
diff --git a/www-apps/gitea/gitea-1.19.3.ebuild b/www-apps/gitea/gitea-1.19.3.ebuild
deleted file mode 100644
index f0f8d4eb4e24..000000000000
--- a/www-apps/gitea/gitea-1.19.3.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 2016-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps go-module tmpfiles systemd flag-o-matic
-
-DESCRIPTION="A painless self-hosted Git service"
-HOMEPAGE="https://gitea.io https://github.com/go-gitea/gitea"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/go-gitea/gitea.git"
-else
- SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-fi
-
-S="${WORKDIR}/${PN}-src-${PV}"
-
-LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
-SLOT="0"
-IUSE="+acct pam sqlite pie"
-
-DEPEND="
- acct? (
- acct-group/git
- acct-user/git[gitea] )
- pam? ( sys-libs/pam )"
-RDEPEND="${DEPEND}
- dev-vcs/git"
-
-DOCS=(
- custom/conf/app.example.ini CONTRIBUTING.md README.md
-)
-FILECAPS=(
- -m 711 cap_net_bind_service+ep usr/bin/gitea
-)
-
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -i -e "s#^MODE = console#MODE = file#" custom/conf/app.example.ini || die
- if use sqlite ; then
- sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
- fi
-}
-
-src_configure() {
- # bug 832756 - PIE build issues
- filter-flags -fPIE
- filter-ldflags -fPIE -pie
-}
-
-src_compile() {
- local gitea_tags=(
- bindata
- $(usev pam)
- $(usex sqlite 'sqlite sqlite_unlock_notify' '')
- )
- local gitea_settings=(
- "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
- "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
- "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
- )
- local makeenv=(
- DRONE_TAG="${PV}"
- LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
- TAGS="${gitea_tags[*]}"
- )
-
- GOFLAGS=""
- if use pie ; then
- GOFLAGS+="-buildmode=pie"
- fi
-
- env "${makeenv[@]}" emake EXTRA_GOFLAGS="${GOFLAGS}" backend
-}
-
-src_install() {
- dobin gitea
-
- einstalldocs
-
- newconfd "${FILESDIR}/gitea.confd-r1" gitea
- newinitd "${FILESDIR}/gitea.initd-r3" gitea
- newtmpfiles - gitea.conf <<-EOF
- d /run/gitea 0755 git git
- EOF
- systemd_newunit "${FILESDIR}"/gitea.service-r3 gitea.service
-
- insinto /etc/gitea
- newins custom/conf/app.example.ini app.ini
- if use acct; then
- fowners root:git /etc/gitea/{,app.ini}
- fperms g+w,o-rwx /etc/gitea/{,app.ini}
-
- diropts -m0750 -o git -g git
- keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
- keepdir /var/log/gitea
- fi
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
- tmpfiles_process gitea.conf
-
- ewarn "The default JWT signing algorithm changed in 1.15.0 from HS256 (symmetric) to"
- ewarn "RS256 (asymmetric). Gitea OAuth2 tokens (and potentially client secrets) will"
- ewarn "need to be regenerated unless you change your JWT_SIGNING_ALGORITHM back to HS256."
- ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.15.0>."
-}