summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-28 11:16:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-28 11:16:27 -0500
commit86e6f64fe7b42b97df3b1ea5afec17ca0220d0ab (patch)
treeec3fe0584777525ea1233c4ab67be71667802b06
parentapp-emulation/docker: sync live ebuild with upstream overlay (diff)
downloadgentoo-86e6f64f.tar.gz
gentoo-86e6f64f.tar.bz2
gentoo-86e6f64f.zip
media-sound/spotify: bup
Package-Manager: portage-2.3.0
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.0.38.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index 6a5604206ca0..5aeaf95cc428 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1,4 @@
DIST spotify-client_1.0.37.152.gc83ea995-42_amd64.deb 79521822 SHA256 9da56b2f696159361bcf6eac0a218ef0a669802f8deb3be17dbf25cb062e0d02 SHA512 c148a4bfdaae14b1d87fa09b6d4c9780fd87e594ae310f8fc1d696be6111214f88ddc239e368faab17d327a5c7ec2b745391d4f114bd41ad9ce6e3b731790609 WHIRLPOOL f49cf8f0ead7a4c436b7491e5c8fc3991133b89e623fc323260a0905b67ef25c26cab0fb6866e8a18a5448110a7e7157c8dc796ae6548469670598f654c7eb6b
DIST spotify-client_1.0.37.152.gc83ea995-42_i386.deb 87737188 SHA256 a5a33f167491455df03f791b818c64e90f4a35b0d83284bb223e15bd4a45f228 SHA512 ef18a4ad61427669c2da00dbd2487882de2cfab191c42cc385f0db230b2bae6b0f03f504c60f5dde67aecc12becb0076727729f6380a7fa88ce01d140965efd1 WHIRLPOOL 64449c68c60c2e46dd16f109a0e3c14f2c844bb9b43ad7cb7d7ab2a3ac603bf34d895637b881341d09f77ef60e82eae513a003b6f494e429899ace42b022bc71
+DIST spotify-client_1.0.38.171.g5e1cd7b2-22_amd64.deb 75021350 SHA256 a0905dbf02657996356e4779dac9554f8679c3e7cb52c6f867213c91385b1956 SHA512 089ef68419ade8bc8370b2a001e08ddde5ad5c131c18be872db124d8c9c502d13d2ac51bb38980d6c2a6dbcfb9ca3b345d5bbe484ad50d9e5522df99f40fe1aa WHIRLPOOL 5dbe641a5844ace83e93fa998793e5bd3c9639f65cbef4c2b8726dabe2acea835fd42f4fb70c5380bf95b71b96495c96eab0521cdba6fdbb20115e9021431bf7
+DIST spotify-client_1.0.38.171.g5e1cd7b2-22_i386.deb 83209544 SHA256 0d6db03c51aea6ad2ddcb5cff2cb3212f209497b4152aac603fbb3ceb2c38586 SHA512 c7bc3d37f252d93d68b0e2387d26bdce8247dba7bf0888180c2b4509eb9ec6319044f3f12c4d0392c43dd04648642390227e9fd2bceeb286c5cc6733de18b0be WHIRLPOOL 722290057d9716b805366ad37883d1ad724356093c3af6514cbee7fa66c91a9116a8ca1ce20a8a3e0a8706de9ff6566da1aeafd6db1d526c2e8552e633a3842f
diff --git a/media-sound/spotify/spotify-1.0.38.ebuild b/media-sound/spotify/spotify-1.0.38.ebuild
new file mode 100644
index 000000000000..5b3c0c07f12f
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.38.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils fdo-mime gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}-client/"
+SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.171.g5e1cd7b2-22_amd64.deb )
+ x86? ( ${SRC_BASE}${PN}-client_${PV}.171.g5e1cd7b2-22_i386.deb )"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=""
+# zenety needed for filepicker
+RDEPEND="
+ ${DEPEND}
+ dev-libs/nss
+ gnome-base/gconf
+ gnome-extra/zenity
+ media-libs/alsa-lib
+ media-libs/harfbuzz
+ media-libs/fontconfig
+ media-libs/mesa
+ net-misc/curl[ssl,curl_ssl_openssl]
+ net-print/cups[ssl]
+ x11-libs/gtk+:2
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ dev-python/pygobject:3
+ dev-python/dbus-python
+ pulseaudio? ( media-sound/pulseaudio )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+ #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ default
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+ ewarn
+ ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
+ ewarn "Run"
+ ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+ ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}