summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-08-17 14:32:03 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-08-17 17:19:20 -0400
commit86ee2059ef3322c2f01aaeac896b1d8a2ccb51ac (patch)
tree8b8b684e7afe5cbbec28a3ac1a46466444770c17
parentdev-perl/Mail-Sender: Keyword 0.903.0-r1 arm64, #857732 (diff)
downloadgentoo-86ee2059.tar.gz
gentoo-86ee2059.tar.bz2
gentoo-86ee2059.zip
dev-qt/qtwebengine: backport :6 favicon display fix
Not worth a revbump rebuild, but is still annoying and wanted to toss it here at least for future builds. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-6.3.1-favicon.patch28
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.3.1.ebuild1
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-6.3.1-favicon.patch b/dev-qt/qtwebengine/files/qtwebengine-6.3.1-favicon.patch
new file mode 100644
index 000000000000..8c9544b16935
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-6.3.1-favicon.patch
@@ -0,0 +1,28 @@
+Backport dev branch fix for favicons sometime not showing in
+some consumers like qutebrowser. Not currently included in
+upcoming 6.3.2 so may be needed beyond 6.3.1.
+
+https://bugreports.qt.io/browse/QTBUG-103735
+https://github.com/qt/qtwebengine/commit/c5de1b2123
+--- a/src/core/favicon_driver_qt.cpp
++++ b/src/core/favicon_driver_qt.cpp
+@@ -300,15 +300,15 @@ void FaviconDriverQt::DidStartNavigation(content::NavigationHandle *navigation_h
+ return;
+
+ m_faviconUrls.reset();
+- m_completedHandlersCount = 0;
+- m_latestFavicon = FaviconStatusQt();
+
+ if (!navigation_handle->IsSameDocument()) {
++ m_completedHandlersCount = 0;
++ m_latestFavicon = FaviconStatusQt();
+ m_documentOnLoadCompleted = false;
+ m_manifestUrl = GURL();
+- }
+
+- m_viewClient->iconChanged(QUrl());
++ m_viewClient->iconChanged(QUrl());
++ }
+
+ content::ReloadType reload_type = navigation_handle->GetReloadType();
+ if (reload_type == content::ReloadType::NONE || IsOffTheRecord())
diff --git a/dev-qt/qtwebengine/qtwebengine-6.3.1.ebuild b/dev-qt/qtwebengine/qtwebengine-6.3.1.ebuild
index 468f7bbc29d7..91f14a1f75cf 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.3.1.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.3.1.ebuild
@@ -88,6 +88,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${P}-widevine.patch
+ "${FILESDIR}"/${P}-favicon.patch
)
python_check_deps() {