summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-14 21:54:54 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-14 23:35:11 +0200
commit86f9687067cbe8f98ccc450a609352306099e717 (patch)
treea180c75467e3f2dd2232a0770ac72df0d4ad6dbc
parentdev-python/boto3: Bump to 1.18.42 (diff)
downloadgentoo-86f96870.tar.gz
gentoo-86f96870.tar.bz2
gentoo-86f96870.zip
app-admin/awscli: Bump to 1.20.42
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.20.42.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index d46e709a6d70..ea8d46e65856 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,3 +1,4 @@
DIST awscli-1.20.28.tar.gz 2058578 BLAKE2B 3f6993a41f46ad9d8d45cebc0d5ea95a954e15c73d236426590c389aba6de6a99b6a5000f065f932733151c14f3112bacc25c670a05d2a991a976669ce54554e SHA512 b75974450cea3744ed15cf00ca82a35aa377c55e0ef67bb5536ed136e768d5030e6707f12e2e7de8bfce48296295ff4ed4c9f9b15c642104ea34c7492291135b
DIST awscli-1.20.40.tar.gz 2071857 BLAKE2B b2511d610c13b4ddf8b1f5c6442f0939072eecf81d97805800bd83b6f481d744ad4344dace6e6553e3d4b7cbf9546f911398311cb04fb698a418579e784539a3 SHA512 aa39a8d67cd8efc63687929f19d5878269ce7f3155a0a64ca2f271251a334f57d2358aa4f0aee76415aee33fe23a1e3b19eb2c6dcfa21e8c0fb7409f5d29a001
DIST awscli-1.20.41.tar.gz 2071927 BLAKE2B 4d7ec9e3c2af3f44cbce9459ef12c8191ae72b3313e266a2ac8f39cd2197129ae66893152c6077326c8315d4098608cb11019ad3cc19fdd057508db4f6c3a0d8 SHA512 6d022575d2bded2245bb17e8605e929a8ff2e91e79f907e21a0eaaf027e2fb657b96573531226cd63a34b0a0523a6747c7c4f9652ee10b09fd8b6d09e9c8fc9c
+DIST awscli-1.20.42.tar.gz 2072504 BLAKE2B 5f6f38f8c96350b670c15cd6cfdd1556cbbfab95b7bfec5ff3ac9a96b56d733bb112b18f04d5d5ce9674a0ebb3d41e7b7f1ad81881c486f99463ce22270e0574 SHA512 29daa2c526b7605fbd1c588b00906f3cdf159570a543cc9c442e28af9f98725b8a0a8f9d61110e90f56744dea6a6abf92f052b85695f3a84bddabb24eff650f6
diff --git a/app-admin/awscli/awscli-1.20.42.ebuild b/app-admin/awscli/awscli-1.20.42.ebuild
new file mode 100644
index 000000000000..ff429f8d3a3e
--- /dev/null
+++ b/app-admin/awscli/awscli-1.20.42.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install nose
+
+PATCHES=(
+ "${FILESDIR}"/awscli-1.19.47-py39.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ nosetests -v tests/{functional,unit} ||
+ die "Tests failed for ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}