summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-07 09:24:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-07 09:24:14 +0100
commit86fdf46ec5d869e6e5c33c662b12d271ba63a1ee (patch)
treee5f7583e1dd958ff91a47886ea1d9eb646b92b47
parentsys-fs/squashfs-tools: Take the package (diff)
downloadgentoo-86fdf46ec5d869e6e5c33c662b12d271ba63a1ee.tar.gz
gentoo-86fdf46ec5d869e6e5c33c662b12d271ba63a1ee.tar.bz2
gentoo-86fdf46ec5d869e6e5c33c662b12d271ba63a1ee.zip
sys-fs/squashfs-tools: Remove the live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-9999.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild b/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild
deleted file mode 100644
index cb91a13dd1ef..000000000000
--- a/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit flag-o-matic git-r3 toolchain-funcs
-
-DESCRIPTION="tools to create and extract Squashfs filesystems"
-HOMEPAGE="
- http://squashfs.sourceforge.net
- https://github.com/plougher/squashfs-tools
-"
-EGIT_REPO_URI="https://github.com/plougher/${PN}"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug lz4 lzma lzo static xattr +xz zstd"
-KEYWORDS=""
-
-LIB_DEPEND="
- !xz? ( !lzo? ( sys-libs/zlib[static-libs(+)] ) )
- lz4? ( app-arch/lz4[static-libs(+)] )
- lzma? ( app-arch/xz-utils[static-libs(+)] )
- lzo? ( dev-libs/lzo[static-libs(+)] )
- sys-libs/zlib[static-libs(+)]
- xattr? ( sys-apps/attr[static-libs(+)] )
- xz? ( app-arch/xz-utils[static-libs(+)] )
- zstd? ( app-arch/zstd[static-libs(+)] )
-"
-RDEPEND="
- !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
-"
-DEPEND="
- ${RDEPEND}
- static? ( ${LIB_DEPEND} )
-"
-use10() { usex $1 1 0 ; }
-
-src_configure() {
-
- # set up make command line variables in EMAKE_SQUASHFS_CONF
- EMAKE_SQUASHFS_CONF=(
- LZ4_SUPPORT=$(use10 lz4)
- LZMA_XZ_SUPPORT=$(use10 lzma)
- LZO_SUPPORT=$(use10 lzo)
- XATTR_SUPPORT=$(use10 xattr)
- XZ_SUPPORT=$(use10 xz)
- ZSTD_SUPPORT=$(use10 zstd)
- )
-
- tc-export CC
- use debug && append-cppflags -DSQUASHFS_TRACE
- use static && append-ldflags -static
-}
-
-src_compile() {
- emake "${EMAKE_SQUASHFS_CONF[@]}" -C ${PN}
-}
-
-src_install() {
- dobin ${PN}/{mksquashfs,unsquashfs}
- dodoc CHANGES README RELEASE-READMEs/*
-}