summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-08-03 20:29:50 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-08-03 20:30:20 +0000
commit872d5f28211f9f667d17a5ef91261b92e57d5b76 (patch)
tree5a5312ecc001dde0834b7d4c5d80338a7e7daef3
parentkde4-meta-pkg.eclass: Mark as dead (diff)
downloadgentoo-872d5f28.tar.gz
gentoo-872d5f28.tar.bz2
gentoo-872d5f28.zip
media-sound/spotify: Version bump - fixes bug 590398.
Thanks to Russell Knighton <russell AT annunaki2k2 DOT co DOT uk>. Package-Manager: portage-2.3.0
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.0.33.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index 1dc5afeaa09f..8e88e0e96bbe 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1,4 @@
DIST spotify-client_1.0.32.96.g3c8a06e6-37_amd64.deb 80185200 SHA256 30c62258e5064150f6e655c410e3a67873d0a5cd079601ea8ec5edd487d3655a SHA512 e3f919c08eb9ddf7431a2ccea466422958d2e79c199418891a223174044a4fe6a3c99182e61640e5bfe1a0995e6cc02973d66ae3a98df873a1a252bca166d6a1 WHIRLPOOL 8b83f8afa94a2e8e32721ca76242f6bfc025dfc84346f96230605e567f043d61838329edc75aa6c7aceb6cfb419c50f38b9625594112a93d1ed82c13a5736714
DIST spotify-client_1.0.32.96.g3c8a06e6-3_i386.deb 86918350 SHA256 a60bb5e78b3849c595bd0c106fd6fbd39f5d7498688182d6a9f5d92c252c0ab7 SHA512 367a3d7953688bd886132a198f293b19975b15c41332d014c395a01de16ae1d92d02d349425a2198911b69f97421d797d312baa7e59f148f91dae23a8d0484cf WHIRLPOOL b17089e0c96949038bfbe492a400b54cc719aa465f204afff3f638f1c96283d7500fd1eddbe06a919ee56631845bd8f8ccb89b06123a6618e2d34465bde8b91e
+DIST spotify-client_1.0.33.106.g60b5d1f0-1_i386.deb 86889986 SHA256 fca0bf364679ab28091071a0406a4072ab0f1b596af0cefae27580eea56ac1e8 SHA512 9c825501cc8558714f935ef68d72b63c4736cc68608c1f081f7c98568e6ca446d07e5ae37e3f30f579b8ad7c0d17df7a672bfd19f497c830c7cc0dbbc4f78242 WHIRLPOOL 4c075ef1df698507e96782ad53aeeecb0e12b4cf3475e5e6df2d896caa0c23cd1681837bc1921bdc0d4cade979b46434dd7110a09f9f8e46aa46abb21de327c2
+DIST spotify-client_1.0.33.106.g60b5d1f0-22_amd64.deb 80179480 SHA256 0e3017382b179b3cc84bd188fccaae12b32ca48dbf197924f6b79066f91121c3 SHA512 55db1b6f1fba5a6ea73917dabd87eb9e9fb40991d341e555b1c74748b95df49013a8a21032273dee933028b8c85eda703cd01d090aba54285f0d966ed1e30386 WHIRLPOOL 78136e199f39290a946c99cd2961070209b5130c3dfc485da7a5c187e339e3128c8409625027e2dac5d805b62563ecb834efebaaec10d4fdfb4d29fc8e815264
diff --git a/media-sound/spotify/spotify-1.0.33.ebuild b/media-sound/spotify/spotify-1.0.33.ebuild
new file mode 100644
index 000000000000..e1738e299daf
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.33.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils fdo-mime gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}-client/"
+SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.106.g60b5d1f0-22_amd64.deb )
+ x86? ( ${SRC_BASE}${PN}-client_${PV}.106.g60b5d1f0-1_i386.deb )"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=""
+# zenety needed for filepicker
+RDEPEND="
+ ${DEPEND}
+ dev-libs/nss
+ gnome-base/gconf
+ gnome-extra/zenity
+ media-libs/alsa-lib
+ media-libs/harfbuzz
+ media-libs/fontconfig
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups[ssl]
+ x11-libs/gtk+:2
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ dev-python/pygobject:3
+ dev-python/dbus-python
+ pulseaudio? ( media-sound/pulseaudio )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+ #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ default
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+ ewarn
+ ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
+ ewarn "Run"
+ ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+ ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}