summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-27 08:06:12 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-27 08:22:21 +0100
commit8730bec8cce6cde316bea144c347ef63544fab1f (patch)
tree8a85854ce8f683019b40f066ff6b9e89368dc8e2
parentdev-python/test_server: Enable py3.8, pypy3 (diff)
downloadgentoo-8730bec8cce6cde316bea144c347ef63544fab1f.tar.gz
gentoo-8730bec8cce6cde316bea144c347ef63544fab1f.tar.bz2
gentoo-8730bec8cce6cde316bea144c347ef63544fab1f.zip
dev-python/PySocks: Bump to 1.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/PySocks/Manifest1
-rw-r--r--dev-python/PySocks/PySocks-1.7.1.ebuild45
-rw-r--r--dev-python/PySocks/files/PySocks-1.7.1-test_server.patch33
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/PySocks/Manifest b/dev-python/PySocks/Manifest
index 7778f15697bc..6a4b9c95d6fa 100644
--- a/dev-python/PySocks/Manifest
+++ b/dev-python/PySocks/Manifest
@@ -1,2 +1,3 @@
DIST PySocks-1.6.7.tar.gz 282874 BLAKE2B 9e4ecf57f6cb9b7690ba68e21b3e52a535a08490b78ad5d8bd90384acf26f16e6a08018eaa7e91763b94182119217404b235425fce146af7e989c5e39e5e07dc SHA512 e49ce2f4ce23fd84ce30a62a5585af3c63980db46e7d427571d8fb8f6b85f4b6aeb37066863491496dd322555a5ce261123d613b8e5819dbdcef8a4e17e5dca0
DIST PySocks-1.6.8.tar.gz 283450 BLAKE2B 72b52fcdb9f3dc3bd71ca75cdbaa159c0b35a81fd4ed9476ab043819dad3efac76615bc751fc6014e1358a13a3a735023bae7f502e2863b5e733982c16758db1 SHA512 9b544cf11464142a5f347cd5688b48422249363a425ccf3887117152f2f1969713674c4bba714242432ae85f3d62e03edeb9cb7b73ebd225ed3b47b3da6896d5
+DIST PySocks-1.7.1.tar.gz 284429 BLAKE2B 8015e8a0a7ebfbb09ec542393aeb633a769701445c07f24bb9e62b07803d7bb605f22e79ad9ec83e47aa7fe843a1a057073d97e25482e742f42e18b2c7a2f1b3 SHA512 cef4a5ce8c67fb485644696a23bf68a721db47f3211212de2d4431eaf9ebd26077dd5a06f6dfa7fde2dcb9d7c1ed551facd014e999929cb4d7b504972c464016
diff --git a/dev-python/PySocks/PySocks-1.7.1.ebuild b/dev-python/PySocks/PySocks-1.7.1.ebuild
new file mode 100644
index 000000000000..09bce5ca993c
--- /dev/null
+++ b/dev-python/PySocks/PySocks-1.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS client module"
+HOMEPAGE="https://github.com/Anorov/PySocks https://pypi.org/project/PySocks/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+#BDEPEND="
+# test? (
+# $(python_gen_cond_dep 'dev-python/test_server[${PYTHON_USEDEP}]' -3)
+# )"
+
+# TODO: unbundle 3proxy
+#distutils_enable_tests pytest
+
+# tests fail semi-randomly; probably starting proxy server doesn't work
+# as expected
+RESTRICT="test"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/PySocks-1.7.1-test_server.patch
+ )
+
+ # requires Internet
+ sed -i -e 's:test_socks5_proxy_connect_timeout:_&:' \
+ test/test_pysocks.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ python_is_python3 || return
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/PySocks/files/PySocks-1.7.1-test_server.patch b/dev-python/PySocks/files/PySocks-1.7.1-test_server.patch
new file mode 100644
index 000000000000..20d208549720
--- /dev/null
+++ b/dev-python/PySocks/files/PySocks-1.7.1-test_server.patch
@@ -0,0 +1,33 @@
+From 983f0451ed25c755da670a682703ae8f7795782b Mon Sep 17 00:00:00 2001
+From: John Vandenberg <jayvdb@gmail.com>
+Date: Wed, 4 Dec 2019 10:44:14 +0700
+Subject: [PATCH] Update tests for test-server 0.0.31
+
+Closes https://github.com/Anorov/PySocks/issues/117
+---
+ requirements_dev.txt | 2 +-
+ test/test_pysocks.py | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/test/test_pysocks.py b/test/test_pysocks.py
+index 49893b2..03d2649 100644
+--- a/test/test_pysocks.py
++++ b/test/test_pysocks.py
+@@ -79,8 +79,7 @@ def setUpClass(cls):
+ from test_server import TestServer
+
+ cls.test_server = TestServer(address=TEST_SERVER_HOST,
+- port=TEST_SERVER_PORT,
+- engine='subprocess')
++ port=TEST_SERVER_PORT)
+ cls.test_server.start()
+
+ @classmethod
+@@ -112,6 +111,7 @@ def assert_proxy_response(self, resp_data, content, address,
+ self.test_server.request['headers']['user-agent'])
+ self.assertEqual('%s:%d' % address,
+ self.test_server.request['headers']['host'])
++ content = b'3\r\n' + content + b'\r\n0'
+ self.assertEqual(content, resp_body)
+ self.assertEqual(client_ip or PROXY_HOST_IP,
+ self.test_server.request['client_ip'])