summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-04 09:08:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-04 09:41:59 +0200
commit87473f42c905a715f9f21dbbcc0de6fc841206c2 (patch)
treeee438635e560dd3ace27da57a90373b4b9f3ee30
parentsci-biology/biopython: Use slot for dev-python/psycopg (diff)
downloadgentoo-87473f42c905a715f9f21dbbcc0de6fc841206c2.tar.gz
gentoo-87473f42c905a715f9f21dbbcc0de6fc841206c2.tar.bz2
gentoo-87473f42c905a715f9f21dbbcc0de6fc841206c2.zip
www-apps/roundup: Use slot for dev-python/psycopg
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--www-apps/roundup/roundup-2.0.0-r1.ebuild (renamed from www-apps/roundup/roundup-2.0.0.ebuild)4
-rw-r--r--www-apps/roundup/roundup-2.1.0-r1.ebuild (renamed from www-apps/roundup/roundup-2.1.0.ebuild)4
2 files changed, 4 insertions, 4 deletions
diff --git a/www-apps/roundup/roundup-2.0.0.ebuild b/www-apps/roundup/roundup-2.0.0-r1.ebuild
index f2b8f1e25bb8..7a5a687eb89b 100644
--- a/www-apps/roundup/roundup-2.0.0.ebuild
+++ b/www-apps/roundup/roundup-2.0.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..9} )
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
@@ -23,7 +23,7 @@ RDEPEND="${DEPEND}
tz? ( dev-python/pytz[$PYTHON_USEDEP] )
sqlite? ( $(python_gen_impl_dep sqlite) )
mysql? ( dev-python/mysqlclient[$PYTHON_USEDEP] )
- postgres? ( >=dev-python/psycopg-2.8[$PYTHON_USEDEP] )
+ postgres? ( >=dev-python/psycopg-2.8:2[$PYTHON_USEDEP] )
xapian? ( >=dev-libs/xapian-bindings-1.0.0[python,$PYTHON_USEDEP] )
whoosh? ( >=dev-python/whoosh-2.5.7[$PYTHON_USEDEP] )
ssl? ( dev-python/pyopenssl[$PYTHON_USEDEP] )
diff --git a/www-apps/roundup/roundup-2.1.0.ebuild b/www-apps/roundup/roundup-2.1.0-r1.ebuild
index 4fce988711fc..46b7a8361e12 100644
--- a/www-apps/roundup/roundup-2.1.0.ebuild
+++ b/www-apps/roundup/roundup-2.1.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
MY_P=${P/_/}
@@ -22,7 +22,7 @@ RDEPEND="${DEPEND}
tz? ( dev-python/pytz[$PYTHON_USEDEP] )
sqlite? ( $(python_gen_impl_dep sqlite) )
mysql? ( dev-python/mysqlclient[$PYTHON_USEDEP] )
- postgres? ( >=dev-python/psycopg-2.8[$PYTHON_USEDEP] )
+ postgres? ( >=dev-python/psycopg-2.8:2[$PYTHON_USEDEP] )
xapian? ( >=dev-libs/xapian-bindings-1.0.0[python,$PYTHON_USEDEP] )
whoosh? ( >=dev-python/whoosh-2.5.7[$PYTHON_USEDEP] )
ssl? ( dev-python/pyopenssl[$PYTHON_USEDEP] )