summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-05 22:32:21 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-05 22:54:26 +0200
commit8763e61390b479ad7c7f8b89635e97855060e2f1 (patch)
treeb207e387b1dee5c8b713602dc78d907d55a88c16
parentdev-python/sphinxcontrib-bibtex: drop old (diff)
downloadgentoo-8763e61390b479ad7c7f8b89635e97855060e2f1.tar.gz
gentoo-8763e61390b479ad7c7f8b89635e97855060e2f1.tar.bz2
gentoo-8763e61390b479ad7c7f8b89635e97855060e2f1.zip
dev-python/simpy: add 4.0.1, enable py3.9 and py3.10
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/simpy/Manifest1
-rw-r--r--dev-python/simpy/simpy-4.0.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/simpy/Manifest b/dev-python/simpy/Manifest
index 7a1bc440fffa..0d8d418e125d 100644
--- a/dev-python/simpy/Manifest
+++ b/dev-python/simpy/Manifest
@@ -1 +1,2 @@
DIST simpy-3.0.13.tar.gz 410773 BLAKE2B 3769782806b4c68554810cc44a5e59e6dbba2fda86a57b225c9c73d62dfe434a55dc1bc16727d0866684b8f43ea69a50bea96dcdc2109a491dd887d9973a51e9 SHA512 7961cb519ec3ad92fddd16204b1741132371c9b9989a9bc9905227fc50ee8baf3c8bbfd65fc12165cb58653114c26179cb3fbe4d09b082062a4180f09d40a259
+DIST simpy-4.0.1.tar.gz 410082 BLAKE2B 09c6f29d2792ac15bb4a3b42a1cdbd4d342aca0ef528aadbe37e01342534645939c9663977230ec7f6f1542a4354925e25f0c5b3bf6e20b29b6da2e69f3d5a90 SHA512 5cc4baada79503e3c2f2425b9f7f00d68f263283ff0cae048fba86665c4dcf70590683f6b7df50d1c1a914ac7cb471ed4b6850676030bea4a3a70fb40eb2cdb4
diff --git a/dev-python/simpy/simpy-4.0.1.ebuild b/dev-python/simpy/simpy-4.0.1.ebuild
new file mode 100644
index 000000000000..89b69982a180
--- /dev/null
+++ b/dev-python/simpy/simpy-4.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1
+
+MY_P="${P/simpy/SimPy}"
+
+DESCRIPTION="Object-oriented, process-based discrete-event simulation language"
+HOMEPAGE="https://simpy.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+# Could not import extension sphinx.builders.epub3 (exception: cannot import
+# name 'StandaloneHTMLBuilder' from partially initialized module
+# 'sphinx.builders.html' (most likely due to a circular import)
+# (/usr/lib/python3.10/site-packages/sphinx/builders/html/__init__.py))
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests --install pytest