summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-28 08:44:46 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-28 09:35:14 +0100
commit877898214b6129211bbe566d11e8f6e12c92ccb7 (patch)
tree16336e5e347a195f1ebb29bac81dbee8543a7c25
parentdev-vcs/git-lfs: Update live ebuild (diff)
downloadgentoo-87789821.tar.gz
gentoo-87789821.tar.bz2
gentoo-87789821.zip
dev-python/construct: Bump to 2.10.58
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/construct/Manifest1
-rw-r--r--dev-python/construct/construct-2.10.58.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
index b18eb085aea4..a327fd2d9ece 100644
--- a/dev-python/construct/Manifest
+++ b/dev-python/construct/Manifest
@@ -1,2 +1,3 @@
DIST construct-2.10.56.tar.gz 1184110 BLAKE2B 01ce1800970826ae3584a9733de171e04dd926e7d19d8b48b4364406b4aa0f4d878ec52f9a7f755bb249aeeaca75ae6221d6bdf302d4342d4974d268b1782175 SHA512 cc9aa126c26a017a3fb7b78a6b8f2056194028a44c8ed615a6dc4a445d50f0463e2de0b80810ab5a252070925a56b5a61dbb601a3de9e445d861356231a146d5
DIST construct-2.10.57.tar.gz 1184585 BLAKE2B abaeebf5872cc97cc67d47cf79370fecdb1abafb62fa80b6acfa63de9087f70fa67fd69e90ab4e78e7ac179c1bb1011529e34201c3c2270e1a2651c97cc678b2 SHA512 ef2f0bbcf4cbcf4862033b16ccb428f84d63ca5c867157b47e38b441cb439c953b543cf69f352c0542525fd07b37d1b3b68910ae5331c482e75b4af937e116a1
+DIST construct-2.10.58.tar.gz 1184881 BLAKE2B d1dfa005542505b0a154f3c0ae74a1708747b1e7b9f5dc650b924169fa54620719bdf5bb868e616ae58e8890f547eaf3bad5b02ef1f7f7ffeeadffaa87413041 SHA512 8547847e3fa15c020ab7d178b229c5b93744b48497c4cf809a93527be5776eacd52783a0fa38583d694c262c119835c989fcbe0936eb247ca844d252c4bdebb5
diff --git a/dev-python/construct/construct-2.10.58.ebuild b/dev-python/construct/construct-2.10.58.ebuild
new file mode 100644
index 000000000000..e67bd28cd5e1
--- /dev/null
+++ b/dev-python/construct/construct-2.10.58.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="https://construct.readthedocs.io/en/latest/ https://pypi.org/project/construct/"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/arrow[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.4[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm tests/test_benchmarks.py || die
+}
+
+pkg_postinst() {
+ ewarn "Version 2.10.x has significant API and implementation changes from"
+ ewarn "previous 2.9.x releases. Please read the documentation at"
+ ewarn "https://construct.readthedocs.io/en/latest/transition210.html"
+ ewarn "for more info."
+}