summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-08 06:13:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-08 06:40:36 +0100
commit877a9b0ff842600425fcaaa1fa7a69f15720f4b9 (patch)
tree77801c0f9158eb3d984af811e5d8e6d780119051
parentdev-python/aws-sam-translator: Bump to 1.86.0 (diff)
downloadgentoo-877a9b0f.tar.gz
gentoo-877a9b0f.tar.bz2
gentoo-877a9b0f.zip
dev-python/shtab: Bump to 1.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/shtab/Manifest1
-rw-r--r--dev-python/shtab/shtab-1.7.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/shtab/Manifest b/dev-python/shtab/Manifest
index 542e422346a9..11b6ad860b90 100644
--- a/dev-python/shtab/Manifest
+++ b/dev-python/shtab/Manifest
@@ -1 +1,2 @@
DIST shtab-1.7.0.tar.gz 45485 BLAKE2B d1aef26a621da7654e5816fda7ebf197cdf23aa3a485716038b6161826b2f1a624caf369bf59a7fd611cc28906debb83f016b167f06c2cfe9d7a53724054ad55 SHA512 82e5bba15007e07c180c5d9585605150f0a5f53b3859888fcdc28c0bc537762635794f7a8ddd6f81f5337d3c7375b925380fc3797198a803fc09635b65dd07f4
+DIST shtab-1.7.1.tar.gz 45410 BLAKE2B 15ed00feb1bb051ad3ec21bab9a3300175b22e677db905b714e29b10308489bec6273a7f1e226b3dd70088c74b0dd5f2c7d8958a130e339d197ba290ea6710f4 SHA512 749f21e5b4eba75744a270809b761e7c795e4404727f8e6da87f6620622e42dc6e35aa923c7f8df34bec27af45ec16496fdab11b8450edb09067df9c830ae219
diff --git a/dev-python/shtab/shtab-1.7.1.ebuild b/dev-python/shtab/shtab-1.7.1.ebuild
new file mode 100644
index 000000000000..3debac670a80
--- /dev/null
+++ b/dev-python/shtab/shtab-1.7.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automagic shell tab completion for Python CLI applications"
+HOMEPAGE="
+ https://github.com/iterative/shtab
+ https://pypi.org/project/shtab/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Disable pytest-cov
+ epytest -o addopts=
+}