summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-01-20 11:17:09 -0500
committerSam James <sam@gentoo.org>2024-01-21 04:26:24 +0000
commit8790ed7ca284d11e3c0fbd5f2762f28dcac2d506 (patch)
tree3d19932515bfcbce8242b7a74319b645a5fac7e8
parentapp-text/xapers: add 0.9.2, use PEP517 (diff)
downloadgentoo-8790ed7ca284d11e3c0fbd5f2762f28dcac2d506.tar.gz
gentoo-8790ed7ca284d11e3c0fbd5f2762f28dcac2d506.tar.bz2
gentoo-8790ed7ca284d11e3c0fbd5f2762f28dcac2d506.zip
dev-libs/log4cxx: add 1.2.0, security bump
Removed unnecessary prepare block now that the build system handles it properly. Bug: https://bugs.gentoo.org/908115 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/34686 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/log4cxx/Manifest1
-rw-r--r--dev-libs/log4cxx/log4cxx-1.2.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/log4cxx/Manifest b/dev-libs/log4cxx/Manifest
index 36dd4b448efa..3edaca4bd2f9 100644
--- a/dev-libs/log4cxx/Manifest
+++ b/dev-libs/log4cxx/Manifest
@@ -1,2 +1,3 @@
DIST apache-log4cxx-0.11.0.tar.gz 1145075 BLAKE2B 786f3374923a5d47172bdaba7edb1725bedc766cb310b7b1237cfcc2fdd84cf2e390b47d55284ad0ce65631798e545523723090f4c0f7ab262f6cbe41a03e327 SHA512 f8aa37c9c094e7a4d6ca92dff13c032f69f1e078c51ea55e284fcb931c13256b08950af3ea6eaf7a12282240f6073e9acab19bfe217f88dbd62a5d2360f3fbdd
DIST apache-log4cxx-1.0.0.tar.gz 554344 BLAKE2B 2664cdcb84c298cd9be49e98ee767f16665614435ad44e79fa4d10219f42373ba8bb3f6cfe698bd65c0565ba120b6f6e1ab7a8de8ce9a1f43e977dde80596c3a SHA512 a6b928d7b5b4fb60a67504be082f436a6d1a750b752a89df51d0660670b6c008e7376cf56c1749fd5fc17777ae8a2d957f72879c9a89487ecb0f179999dc1283
+DIST apache-log4cxx-1.2.0.tar.gz 652992 BLAKE2B b20211dfc0fc722e5b34adea9b4f6009f827f5fae467d8e0ec097c9b8915b8413494232704eb49e062b7c18f53fc9240b244c093a3d54c1964a7f7b4ba41fe00 SHA512 377234407c5f1128fbff6e5d2fcda3f53aae275962cd9207257674fa016095f4bc4ac0c318c1ba2a75f3252402cce0776c1211ffa917a60f8a89a12f01d45efb
diff --git a/dev-libs/log4cxx/log4cxx-1.2.0.ebuild b/dev-libs/log4cxx/log4cxx-1.2.0.ebuild
new file mode 100644
index 000000000000..dc2e7294b417
--- /dev/null
+++ b/dev-libs/log4cxx/log4cxx-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P=apache-${P}
+DESCRIPTION="Library of C++ classes for logging to files, syslog and other destinations"
+HOMEPAGE="https://logging.apache.org/log4cxx/"
+SRC_URI="mirror://apache/logging/${PN}/${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/15"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="odbc smtp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/apr:1=
+ dev-libs/apr-util:1=
+ dev-libs/libfmt:=
+ odbc? ( dev-db/unixODBC )
+ smtp? ( net-libs/libesmtp )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/zip
+ test? (
+ app-alternatives/gzip
+ app-arch/zip
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_FMT_LAYOUT=ON
+ -DLOG4CXX_QT_SUPPORT=OFF
+ -DLOG4CXX_ENABLE_ODBC=$(usex odbc ON OFF)
+ -DLOG4CXX_ENABLE_ESMTP=$(usex smtp ON OFF)
+ )
+
+ cmake_src_configure
+}