summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-09-21 11:02:25 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-09-21 11:02:25 +0200
commit8791b7b9d902fba6776ce1a4f1952377cd395d8e (patch)
tree20358e7d45c418597cb5b3d4cbc6f7f29983e5bf
parentsys-fs/bcache-tools: sync live (diff)
downloadgentoo-8791b7b9d902fba6776ce1a4f1952377cd395d8e.tar.gz
gentoo-8791b7b9d902fba6776ce1a4f1952377cd395d8e.tar.bz2
gentoo-8791b7b9d902fba6776ce1a4f1952377cd395d8e.zip
sys-fs/bcache-tools: use upstream's 'install' target
This hopefully reduces the chances that new binaries and similar things are not installed when bumping the package. Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--sys-fs/bcache-tools/bcache-tools-1.1_p20230217-r1.ebuild (renamed from sys-fs/bcache-tools/bcache-tools-1.1_p20230217.ebuild)32
1 files changed, 18 insertions, 14 deletions
diff --git a/sys-fs/bcache-tools/bcache-tools-1.1_p20230217.ebuild b/sys-fs/bcache-tools/bcache-tools-1.1_p20230217-r1.ebuild
index 88fe95d15846..9577ad30f308 100644
--- a/sys-fs/bcache-tools/bcache-tools-1.1_p20230217.ebuild
+++ b/sys-fs/bcache-tools/bcache-tools-1.1_p20230217-r1.ebuild
@@ -37,29 +37,33 @@ src_prepare() {
sed \
-e '/^CFLAGS/s:-O2::' \
-e '/^CFLAGS/s:-g::' \
+ -e '/.*INSTALL.*share\/man/d' \
+ -e '/.*INSTALL.*bcache-status/d' \
-i Makefile || die
append-lfs-flags
}
src_install() {
- into /
- dosbin bcache make-bcache bcache-super-show
-
- exeinto $(get_udevdir)
- doexe bcache-register probe-bcache
+ local udevdir="$(get_udevdir)"
+
+ local mydirs=(
+ sbin
+ "${udevdir}/rules.d"
+ /usr/share/initramfs-tools/hooks/bcache
+ /usr/lib/initcpio/install/bcache
+ )
+ dodir "${mydirs[@]}"
+
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}" \
+ UDEVLIBDIR="${udevdir}" \
+ DRACUTLIBDIR="/usr/lib/dracut" \
+ install
python_foreach_impl python_doscript bcache-status
- udev_dorules 69-bcache.rules
-
- insinto /etc/initramfs-tools/hooks/bcache
- doins initramfs/hook
-
- # that is what dracut does
- insinto /usr/lib/dracut/modules.d/90bcache
- doins dracut/module-setup.sh
-
doman *.8
dodoc README