summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2017-11-15 06:59:58 +0100
committerDavide Pesavento <pesa@gentoo.org>2017-11-15 06:59:58 +0100
commit87a182adc2538718a1c8a12e3cbad0ba4fc878d8 (patch)
treedc33bb9bc82132f60cf05cf5ec2f328292824257
parentdev-php/PEAR-Crypt_GPG: remove unused PEAR-Crypt_GPG-1.6.0.ebuild. (diff)
downloadgentoo-87a182adc2538718a1c8a12e3cbad0ba4fc878d8.tar.gz
gentoo-87a182adc2538718a1c8a12e3cbad0ba4fc878d8.tar.bz2
gentoo-87a182adc2538718a1c8a12e3cbad0ba4fc878d8.zip
dev-libs/qcustomplot: version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.4
-rw-r--r--dev-libs/qcustomplot/Manifest2
-rw-r--r--dev-libs/qcustomplot/qcustomplot-2.0.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/qcustomplot/Manifest b/dev-libs/qcustomplot/Manifest
index fa7b3a139def..7e2e7994754d 100644
--- a/dev-libs/qcustomplot/Manifest
+++ b/dev-libs/qcustomplot/Manifest
@@ -1,2 +1,4 @@
DIST qcustomplot-sharedlib-1.3.2.tar.gz 1924 SHA256 18af836d2ac32f0dc2a4b1485c3038f4f5f3acf07550d86077ba5871e54bb269 SHA512 645d71c9d63ccd324f341778556f0b9ddceb3fee87b037c66f7ea7624973e24e292da7539861ffa1c8545cc0691a1041110b25d688f0b3d8787a44798a5e190e WHIRLPOOL d7ff5ffa460ac6b05816f1705f29ea82bbd709ca131ad3dc496abab1e718524f1dbe536dfaf726b0508143dbc76256a080fad8544c4e4412e58b980309e1aa2a
+DIST qcustomplot-sharedlib-2.0.0.tar.gz 1949 SHA256 e5998b883dc7af8aa0260f4eccc5dfa1ed011094df842414c5d6ce95a4ddd9f6 SHA512 f4ba719287067c2bb999a6e4ffb3694b32b1d72867c396fee1834ba2916f2931eda07bbe25c4d2ea6f6af18bd78917660dc6eabd98f72c9da987ae288ed4e611 WHIRLPOOL 33388defb8eec382c81c15facfd3f38401dfd5eacd594344e72740950c1a6551e447e9e3a471ba0b041ade9086184fe4dd1b37d9c545a2c1b3fcef0b3a0eb5e1
DIST qcustomplot-source-1.3.2.tar.gz 225912 SHA256 a3649824c6d2d08efb0b54629e6ffe4cc57fa08ad9eb9f39edbb0c30b9659b51 SHA512 0e9fefd3f6e4428009428d3155b1a26e1d4b2a62567ca7812cefa67c06fa53f301229d8bd2c3abbe0fb7ddacb9a07515522ded56c0745cd31b1f85323d4499fb WHIRLPOOL fb5c59c71aee5fc95af9a75054f7a41a28eac7c70f296cf1b0dc4a58927f73b94a5b02203b520e367f673e4741959d195cebe6f50141be8157122aa249ea6c4a
+DIST qcustomplot-source-2.0.0.tar.gz 317398 SHA256 68b4502d6aac502b0630724e95e07abeb8246a68448a78f62661f58abee9a815 SHA512 66c648877ed0a14cf527ac8526788065f494119cc61993d20268a0046c8e6c5a1c73a61f50a73e6a39ec55435bc5f74c613ee21254293ddab34ba7c2484c4f5a WHIRLPOOL 49637db58cb0996c2b2574632e97156bd753097c924d93b46e57cc6284f42a03b76415a96fd6372400fe9c89f0d09bddef50bb9b9253f0d9455f99e8461c5392
diff --git a/dev-libs/qcustomplot/qcustomplot-2.0.0.ebuild b/dev-libs/qcustomplot/qcustomplot-2.0.0.ebuild
new file mode 100644
index 000000000000..fdd27dd99daf
--- /dev/null
+++ b/dev-libs/qcustomplot/qcustomplot-2.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Qt C++ widget for plotting and data visualization"
+HOMEPAGE="http://www.qcustomplot.com/"
+SRC_URI="
+ http://www.qcustomplot.com/release/${PV}/QCustomPlot-sharedlib.tar.gz -> ${PN}-sharedlib-${PV}.tar.gz
+ http://www.qcustomplot.com/release/${PV}/QCustomPlot-source.tar.gz -> ${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-source
+
+src_prepare() {
+ default
+
+ sed \
+ -e 's:../../::g' \
+ -e '/CONFIG/s:shared.*:shared:g' \
+ "${WORKDIR}"/${PN}-sharedlib/sharedlib-compilation/sharedlib-compilation.pro > ${PN}.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ dolib.so lib${PN}*
+ doheader ${PN}.h
+ dodoc changelog.txt
+}