summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <rahil3108@gmail.com>2023-09-29 14:46:40 +0530
committerFlorian Schmaus <flow@gentoo.org>2023-10-18 20:48:35 +0200
commit87b67cf8a5d413bd44564f5fb8107a2573d86047 (patch)
treec339ee842de04b540fceab3d6fc3ffbe521464ca
parentmedia-video/pipewire: backport upstream fixes to 0.3.82 (diff)
downloadgentoo-87b67cf8a5d413bd44564f5fb8107a2573d86047.tar.gz
gentoo-87b67cf8a5d413bd44564f5fb8107a2573d86047.tar.bz2
gentoo-87b67cf8a5d413bd44564f5fb8107a2573d86047.zip
app-containers/podman-tui: add 0.11.0 and live
Terminal UI frontend for Podman Signed-off-by: Rahil Bhimjiani <rahil3108@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33116 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--app-containers/podman-tui/Manifest1
-rw-r--r--app-containers/podman-tui/metadata.xml17
-rw-r--r--app-containers/podman-tui/podman-tui-0.11.0.ebuild34
-rw-r--r--app-containers/podman-tui/podman-tui-9999.ebuild34
4 files changed, 86 insertions, 0 deletions
diff --git a/app-containers/podman-tui/Manifest b/app-containers/podman-tui/Manifest
new file mode 100644
index 000000000000..165d9ec746e2
--- /dev/null
+++ b/app-containers/podman-tui/Manifest
@@ -0,0 +1 @@
+DIST podman-tui-0.11.0.tar.gz 13317542 BLAKE2B 0492799b7e61eaa75344392d824be6f41bac0b61510587cca936ec2e5f516e2513e709d739e66cd86a658fa916f61a02dbf0802a3761bab2ccb11705c3d514f3 SHA512 1b5ce216829a0f2ef345920ea908a5f721ee704bf3c7efe121e42c413edb84fb247eb32964fcd7928c734df93efd85a3c1fb5a92b0e6f3c1de3b4906fbc77fe2
diff --git a/app-containers/podman-tui/metadata.xml b/app-containers/podman-tui/metadata.xml
new file mode 100644
index 000000000000..a42c7454a3f3
--- /dev/null
+++ b/app-containers/podman-tui/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>rahil3108@gmail.com</email>
+ <name>Rahil Bhimjiani</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">containers/podman-tui</remote-id>
+ <bugs-to>https://github.com/containers/podman-tui/issues</bugs-to>
+ <doc>https://github.com/containers/podman-tui/blob/main/README.md</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/app-containers/podman-tui/podman-tui-0.11.0.ebuild b/app-containers/podman-tui/podman-tui-0.11.0.ebuild
new file mode 100644
index 000000000000..58c2601964d0
--- /dev/null
+++ b/app-containers/podman-tui/podman-tui-0.11.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+DESCRIPTION="Terminal UI frontend for Podman"
+HOMEPAGE="https://github.com/containers/podman-tui"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/podman-tui.git"
+else
+ SRC_URI="https://github.com/containers/podman-tui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0 BSD-2 BSD MIT MPL-2.0"
+SLOT="0"
+RESTRICT="test"
+RDEPEND="
+ >=app-containers/podman-4.0.2
+"
+
+src_compile() {
+ # parse tags from Makefile & make them comma-seperated as space-seperated list is deprecated
+ local BUILDTAGS=$(grep 'BUILDTAGS :=' Makefile | awk -F\" '{ print $2; }' | sed -e 's| |,|g;')
+ ego build -tags "${BUILDTAGS}"
+}
+
+src_install() {
+ dobin "${PN}"
+ einstalldocs
+}
diff --git a/app-containers/podman-tui/podman-tui-9999.ebuild b/app-containers/podman-tui/podman-tui-9999.ebuild
new file mode 100644
index 000000000000..58c2601964d0
--- /dev/null
+++ b/app-containers/podman-tui/podman-tui-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+DESCRIPTION="Terminal UI frontend for Podman"
+HOMEPAGE="https://github.com/containers/podman-tui"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/podman-tui.git"
+else
+ SRC_URI="https://github.com/containers/podman-tui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0 BSD-2 BSD MIT MPL-2.0"
+SLOT="0"
+RESTRICT="test"
+RDEPEND="
+ >=app-containers/podman-4.0.2
+"
+
+src_compile() {
+ # parse tags from Makefile & make them comma-seperated as space-seperated list is deprecated
+ local BUILDTAGS=$(grep 'BUILDTAGS :=' Makefile | awk -F\" '{ print $2; }' | sed -e 's| |,|g;')
+ ego build -tags "${BUILDTAGS}"
+}
+
+src_install() {
+ dobin "${PN}"
+ einstalldocs
+}