summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-08-29 14:06:18 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-08-29 14:06:18 -0500
commit87be1248ad724745a87196ef5e187cb450f25d5e (patch)
tree6c45485aa828af7a1170c7657e8c29a00d3a32f2
parentnet-libs/gnutls: fix libtasm1 dependency (diff)
downloadgentoo-87be1248.tar.gz
gentoo-87be1248.tar.bz2
gentoo-87be1248.zip
dev-python/stormpath: add version 2.0.9
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-python/stormpath/Manifest1
-rw-r--r--dev-python/stormpath/stormpath-2.0.9.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/stormpath/Manifest b/dev-python/stormpath/Manifest
index 9ad4b51c6a96..3c85105c1905 100644
--- a/dev-python/stormpath/Manifest
+++ b/dev-python/stormpath/Manifest
@@ -1 +1,2 @@
DIST stormpath-2.0.8.tar.gz 4326469 SHA256 9f6ad7e7b210024915e2139b2ed395a7c0fff6ca49ad3cdf58dc8f214d080c70 SHA512 661714fac02528111bb01e30f8c16b1d8701fe894b21d803958331819ce145a9ec03864111b861286224b33aaf56ca68ddcef2b67cd0003c498cd007ce375a03 WHIRLPOOL 12e6f7ec559a654ab59d34106d85d98ada4c7e3dee6fcec6cad0a2500608e962289d73a50e6ce6d81122c43f0f53b30d861203c8a976ac7bdbdab1cd8f5db6be
+DIST stormpath-2.0.9.tar.gz 4325976 SHA256 ba93f1f9f6b98db2eb2671d2b3285fdd15f8b2e6d3bce899f240576018f216ae SHA512 b50fa11e8fecf4909a8a1014963c80e7e2dde4db37e1f4681c2a116933d59f5b5ea32901cfde97b24398d8074db8b04121b2a7715d86b6b2eb78eb288465114c WHIRLPOOL 6290d5844d35158cc46f1810b6f83e41c443164cff4512caeeb38e562b04f448c1ac1b608b2cda4abd348f91319e4e8fbb3b195ba31a8fb415ba80f0ed7c5937
diff --git a/dev-python/stormpath/stormpath-2.0.9.ebuild b/dev-python/stormpath/stormpath-2.0.9.ebuild
new file mode 100644
index 000000000000..084b5d1b7b73
--- /dev/null
+++ b/dev-python/stormpath/stormpath-2.0.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Official Stormpath SDK, used to interact with the Stormpath REST API."
+HOMEPAGE="https://github.com/stormpath/stormpath-sdk-python"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/oauthlib-0.6.3[${PYTHON_USEDEP}]
+ >=dev-python/pydispatcher-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test || die "tests failed under ${EPYTYHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}