summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-25 22:21:03 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-25 22:21:03 +0300
commit87d90ad15f1357cf5694c5f0f58ca0afa342cf0a (patch)
treedfcf453bbd8c3cda06ee821552df80870f741580
parentdev-python/cfn-lint: add 0.63.0 (diff)
downloadgentoo-87d90ad1.tar.gz
gentoo-87d90ad1.tar.bz2
gentoo-87d90ad1.zip
dev-python/jupyter_client: add 7.3.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.3.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index 9f582e55af80..e3d196138f18 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1 +1,2 @@
DIST jupyter_client-7.3.4.tar.gz 329871 BLAKE2B 34f4cc01ced39e30f81e0c7524ada9319f7bea6fb0f941dad85ac3f969de71b68bde22359a9d343df84432e320994a8c4c4aa9ebd390b841e4b18042ac6f0b14 SHA512 3bb1fd7c93e16c03db0c249810fe48428dc9c1fa24ae885a3d30b4ac2d2e980f48edc06c2c6065b3e8f91610bf5bc7500854986f55c18bd9f695f192aa470beb
+DIST jupyter_client-7.3.5.tar.gz 326758 BLAKE2B c2ac76eb6511b29c38d7e7441e1191bae1f931da27f2eb95d6cb842a0e36f36a6f7a1421253b62abf52243f9fdad36b34828e6d5cd13a0411fa4ce09b447c3bc SHA512 5a3471fe03f44671fc2a06f8c78c11197084c8c951a1f8b55b89d651a6aea2ae1bdbb451ed463e52519954e7dba99b4e2298a6511eef2a3618f095dc864758d9
diff --git a/dev-python/jupyter_client/jupyter_client-7.3.5.ebuild b/dev-python/jupyter_client/jupyter_client-7.3.5.ebuild
new file mode 100644
index 000000000000..8b28df440476
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-7.3.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.9.2[${PYTHON_USEDEP}]
+ >=dev-python/nest_asyncio-1.5.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.5[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.0.6-test-timeout.patch
+)
+
+distutils_enable_tests pytest