summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-17 01:53:42 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-17 02:22:11 +0100
commit87e8b8eb0c739ac1415365fbec6188f6734657d0 (patch)
tree07613ed59ff6cd82df835f9aec135a94a81ce85b
parentsci-mathematics/coq-serapi: drop old 0.16.0-r1 (diff)
downloadgentoo-87e8b8eb0c739ac1415365fbec6188f6734657d0.tar.gz
gentoo-87e8b8eb0c739ac1415365fbec6188f6734657d0.tar.bz2
gentoo-87e8b8eb0c739ac1415365fbec6188f6734657d0.zip
app-emacs/citar: bump to 1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/citar/Manifest1
-rw-r--r--app-emacs/citar/citar-1.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/citar/Manifest b/app-emacs/citar/Manifest
index 1eac9a440400..aa078ac35d44 100644
--- a/app-emacs/citar/Manifest
+++ b/app-emacs/citar/Manifest
@@ -1 +1,2 @@
DIST citar-1.0.tar.gz 1339812 BLAKE2B 2093cc820199219ec70f99a746c630f2b8e6b4d464b1457d7b7db1c5c953138e7dd5ac55e21b13e7417dd0a764b6f1caaf400af353ecce9fb7e1bc578f570b0d SHA512 7f02a4e41a927c2c7c625189fa38caea8f0fc5616dd3487a93f71a373d1e4a124dd1cc520778a1ff2fa6dd7c3b619b539e3b0e47cb9caf7edd16e27e9d739585
+DIST citar-1.1.tar.gz 1340039 BLAKE2B b2090a35a582918300f5e4bb2188d463630988830305aa4bb5e1e27f45ff8c96ca35458e610e13658b2120af497f9b877054a6fbebda48e0a4d87824ef48e9c8 SHA512 2b1924ef1a05a170eea31f844055b914410cd35613eda6604f08164818a8fc5480fc5a6d6f055ba95331b517305e51a6e671214cc88fccbda2430ae9b06dda49
diff --git a/app-emacs/citar/citar-1.1.ebuild b/app-emacs/citar/citar-1.1.ebuild
new file mode 100644
index 000000000000..9c62e000f5a7
--- /dev/null
+++ b/app-emacs/citar/citar-1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs package to quickly find and act on bibliographic references"
+HOMEPAGE="https://github.com/emacs-citar/citar/"
+SRC_URI="https://github.com/emacs-citar/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-emacs/citeproc-el
+ app-emacs/parsebib
+"
+BDEPEND="${RDEPEND}"
+
+# Embark integration has it's own package on MELPA, and it is probably better
+# to split them. https://melpa.org/#/citar-embark
+ELISP_REMOVE="citar-embark.el"
+
+DOCS=( CHANGELOG.org CONTRIBUTING.org README.org images )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l test/citar-file-test.el \
+ -l test/citar-format-test.el \
+ -l test/citar-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}