summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2016-09-13 14:40:43 +0200
committerTiziano Müller <dev-zero@gentoo.org>2016-09-13 14:53:06 +0200
commit87ee865324c93a060ef7297e3550245a4bfaec32 (patch)
tree4c65fc0826fc6fe67fe6d4331e9fa7c91ee15be9
parentdev-ml/ocaml-extunix: add missing dep on camlp4; bug #593642 (diff)
downloadgentoo-87ee865324c93a060ef7297e3550245a4bfaec32.tar.gz
gentoo-87ee865324c93a060ef7297e3550245a4bfaec32.tar.bz2
gentoo-87ee865324c93a060ef7297e3550245a4bfaec32.zip
dev-python/flask-testing: version bump (including EAPI bump and py-3.5 support)
Package-Manager: portage-2.3.0
-rw-r--r--dev-python/flask-testing/Manifest1
-rw-r--r--dev-python/flask-testing/flask-testing-0.6.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/flask-testing/Manifest b/dev-python/flask-testing/Manifest
index 338d697104f0..353a2248284a 100644
--- a/dev-python/flask-testing/Manifest
+++ b/dev-python/flask-testing/Manifest
@@ -1,2 +1,3 @@
DIST Flask-Testing-0.4.1.tar.gz 39879 SHA256 d8c4d97d79de517a5d6e348bcc6aaccc45832827afa25ca15cdf8a5a16e543a2 SHA512 b7b71a40545aebed2616b5867951078930bc5d2ab6bf4bc259fab4f8d127ace3830f71bdb4a654c96bf5379bce49930c84e77486c8111b0645bfc515428592b0 WHIRLPOOL e3310b41b53da9847ad3143db30359af8a3eb515da42cc4ffc3068d681abb78a8d11302fb26d085197627aae7d7408175819a108dcf25fd2c0270e02ceaef9b7
DIST Flask-Testing-0.4.2.tar.gz 40994 SHA256 921c7c653e0d511ed87fbf70d984e27afea8dfa7e10b358689863d7a63e05321 SHA512 57f1a58f352637b6c1d4dc5aa8b3cac215eae334f355d40b6c777f9c5a769c745ce11f2a98818669ec2c29fc170fd86fe4670bb66bd4e4607174b21c5c2067e3 WHIRLPOOL a1fc0723660c25cb18ea5eb4c283c79eb379f2d8cee1bf8fda6ed8b10391cdf0080fa3e2e1ce6cdc50845548a5d9be3f4b20ef267c1350a14049adfbdcfa8e20
+DIST Flask-Testing-0.6.1.tar.gz 42541 SHA256 abf539332c013aee5301cbb720d2c6a78bb69fe9bcf854697b6f62f1e7f175b2 SHA512 f7a0a89885693f568e8e03a9ae689add3b9577517faa6b842bb6b990a2be447ecb9ccf693dd5279ca98dfcc8b18e2041fccf0cf36c28cea5fdc0dbdc9b64f065 WHIRLPOOL 456c7c834f3ed9806fd830f64873f43ac6707cdc195ac2e4c7ae9083987b967a8e2bc0250df1a5247f5512483b39272bf3a3bc53642180990b6269a619eb8b12
diff --git a/dev-python/flask-testing/flask-testing-0.6.1.ebuild b/dev-python/flask-testing/flask-testing-0.6.1.ebuild
new file mode 100644
index 000000000000..c0ab7383354b
--- /dev/null
+++ b/dev-python/flask-testing/flask-testing-0.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+MY_PN="Flask-Testing"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Unit testing for Flask"
+HOMEPAGE="http://pythonhosted.org/Flask-Testing/ https://pypi.python.org/pypi/Flask-Testing/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/twill[${PYTHON_USEDEP}]' 'python2*')"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ local exclude
+ if $(python_is_python3); then
+ # Twill is not available on python-3
+ exclude="-e twill"
+ fi
+ # test phase appears to run only py2.7 but if it passes for py2.7 is passes for pypy
+ nosetests ${exclude} || die "Testing failed with ${EPYTHON}"
+}