summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 21:08:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 21:08:24 +0200
commit881c4ba6594d1651ad4112891b805133de4754d6 (patch)
tree228880d2696eb388a904ed7207103db57d1a0157
parentx11-wm/mutter: Block buggy GTK versions (diff)
downloadgentoo-881c4ba6.tar.gz
gentoo-881c4ba6.tar.bz2
gentoo-881c4ba6.zip
dev-python/send2trash: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/send2trash/send2trash-1.8.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/send2trash/send2trash-1.8.0-r1.ebuild b/dev-python/send2trash/send2trash-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..9f01dfbdd6d4
--- /dev/null
+++ b/dev-python/send2trash/send2trash-1.8.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sends files to the Trash (or Recycle Bin)"
+HOMEPAGE="
+ https://github.com/arsenetar/send2trash/
+ https://pypi.org/project/Send2Trash/
+"
+SRC_URI="
+ https://github.com/arsenetar/send2trash/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest