summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-24 15:07:34 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-24 15:30:31 +0100
commit8820595905904cd3354033b810ccfffcf3b8269d (patch)
tree7d21f3b33703c4afc3f788e07bd2f6bda418825b
parentsci-libs/plplot: add 5.15.0_p6 (diff)
downloadgentoo-8820595905904cd3354033b810ccfffcf3b8269d.tar.gz
gentoo-8820595905904cd3354033b810ccfffcf3b8269d.tar.bz2
gentoo-8820595905904cd3354033b810ccfffcf3b8269d.zip
sci-libs/xylib: Use wxGTK 3.2
And provide a proper menu entry Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sci-libs/xylib/xylib-1.6-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/xylib/xylib-1.6-r1.ebuild b/sci-libs/xylib/xylib-1.6-r1.ebuild
new file mode 100644
index 000000000000..1428662cc66d
--- /dev/null
+++ b/sci-libs/xylib/xylib-1.6-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+WX_GTK_VER=3.2-gtk3
+
+inherit desktop wxwidgets
+
+DESCRIPTION="Experimental x-y data reading library"
+HOMEPAGE="https://github.com/wojdyr/xylib"
+SRC_URI="https://github.com/wojdyr/xylib/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 gui zlib"
+
+RDEPEND="
+ bzip2? ( app-arch/bzip2 )
+ gui? ( x11-libs/wxGTK:${WX_GTK_VER} )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+
+src_configure() {
+ use gui && setup-wxwidgets
+
+ econf \
+ --disable-static \
+ $(use_with bzip2 bzlib) \
+ $(use_with gui) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ newicon gui/xyconvert48.xpm xyconvert.xpm
+ make_desktop_entry xyconvert xyConvert xyconvert.xpm
+}