summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-25 21:03:01 +0100
committerSam James <sam@gentoo.org>2022-10-25 21:12:10 +0100
commit8856758f95b1110b87089ef0f9d358754cf77f3a (patch)
tree7a435abb92ec083f17010265b00cd2b39b37561a
parentx11-libs/gdk-pixbuf: Drop unnecessary sed (diff)
downloadgentoo-8856758f95b1110b87089ef0f9d358754cf77f3a.tar.gz
gentoo-8856758f95b1110b87089ef0f9d358754cf77f3a.tar.bz2
gentoo-8856758f95b1110b87089ef0f9d358754cf77f3a.zip
dev-perl/GD: add 2.760.0
Closes: https://bugs.gentoo.org/867835 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-perl/GD/GD-2.760.0.ebuild79
-rw-r--r--dev-perl/GD/Manifest1
-rw-r--r--dev-perl/GD/files/GD-2.760.0-respect-libdir.patch39
3 files changed, 119 insertions, 0 deletions
diff --git a/dev-perl/GD/GD-2.760.0.ebuild b/dev-perl/GD/GD-2.760.0.ebuild
new file mode 100644
index 000000000000..f722bb933ed8
--- /dev/null
+++ b/dev-perl/GD/GD-2.760.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=RURBAN
+DIST_VERSION=2.76
+DIST_EXAMPLES=("demos/*")
+inherit perl-module
+
+DESCRIPTION="Interface to Thomas Boutell's gd library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="animgif fcgi test truetype xpm"
+
+RDEPEND="
+ >=media-libs/gd-2.2.3[png,jpeg]
+ media-libs/giflib
+ media-libs/libjpeg-turbo
+ media-libs/libpng
+ sys-libs/zlib
+ truetype? (
+ media-libs/gd[truetype]
+ media-libs/freetype:2
+ )
+ xpm? (
+ media-libs/gd[xpm]
+ x11-libs/libXpm
+ )
+ fcgi? (
+ dev-libs/fcgi
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-Constant-0.230.0
+ dev-perl/ExtUtils-PkgConfig
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Fork-0.20.0
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.760.0-respect-libdir.patch
+)
+
+src_configure() {
+ local myconfargs=(
+ VERSION_33
+ GD_UNCLOSEDPOLY
+ GD_FTCIRCLE
+
+ JPEG
+ PNG
+ GIF
+ )
+
+ # The following flags do not work properly. This is why we force-enable
+ # at least some of them. See bug 787404 as tracker.
+ use animgif && myconfargs+=( ANIMGIF )
+ use truetype && myconfargs+=( FT )
+ use xpm && myconfargs+=( XPM )
+
+ # Per line 284 of Makefile.PL
+ local myconf="--lib_gd_path ${ESYSROOT}/usr/$(get_libdir) -options '$(printf '%s,' ${myconfargs[@]})'"
+ use fcgi && myconf+=" --fcgi"
+
+ perl-module_src_configure
+}
+
+src_test() {
+ # The 'GD' format itself is long-obsolete and gone in >=media-libs/gd-2.3.3
+ perl_rm_files t/z_*.t t/GD.t
+ perl-module_src_test
+}
diff --git a/dev-perl/GD/Manifest b/dev-perl/GD/Manifest
index ebf4412eb6d3..adbcdd38fbe4 100644
--- a/dev-perl/GD/Manifest
+++ b/dev-perl/GD/Manifest
@@ -1 +1,2 @@
DIST GD-2.73.tar.gz 261203 BLAKE2B 088cb4d3c846d61e89631c7fef6b0273489297f0613e1ebb98c33b404a613431c79a5e72c2b757450496ef8d86aabe387b102a4c8d22d69532b8d8e989bac9bf SHA512 0c360c86307c8a2484bd8e1fb4cf24e27f7976bcfd830d9070fdc3775d233845734c59796082d498276aa715f30c9452c492b0d5bd75e488c1e9c5fa76490709
+DIST GD-2.76.tar.gz 264364 BLAKE2B 4cfe36f74aae50141f00cd8d3a6eddbf819dafd76ecfc1fbf219c3ae40009b9e4c1e6b94a33416842846dead17bfc1f883324757fd66124aae8e2cbae2bcfef3 SHA512 31c2d61440a7fef9804aed677ee5568f6c237e678cf5a2b7f48e98326ef7cddbf3624ce3965e6711ef9cec4148881a0cb4352c19b91ead4b78835fafaeefbe4d
diff --git a/dev-perl/GD/files/GD-2.760.0-respect-libdir.patch b/dev-perl/GD/files/GD-2.760.0-respect-libdir.patch
new file mode 100644
index 000000000000..3651cc3283e2
--- /dev/null
+++ b/dev-perl/GD/files/GD-2.760.0-respect-libdir.patch
@@ -0,0 +1,39 @@
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -56,12 +56,6 @@ END
+
+ @LIBS = qw(-lgd) unless @LIBS;
+
+-# support for AMD64 libraries
+-if (-d '/usr/lib64') {
+- my @libs64 = map {my $a = $_; $a=~ s/lib$/lib64/; $a} @LIBPATH;
+- @LIBPATH = (@LIBPATH,@libs64);
+-}
+-
+ #############################################################################################
+ # Build options passed in to script to support reproducible builds via Makefiles
+ #############################################################################################
+@@ -219,12 +213,6 @@ if( ! defined($lib_gd_path) )
+ $PREFIX = prompt('Where is libgd installed?','/usr/lib');
+ }
+
+-unless ($AUTOCONFIG || $PREFIX eq '/usr/lib') {
+- $PREFIX =~ s!/lib$!!;
+- unshift @INC,"-I$PREFIX/include";
+- unshift @LIBPATH,"-L$PREFIX/lib";
+-}
+-
+ # FEATURE FLAGS
+
+ ##################################################################################################################
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -514,7 +514,7 @@ sub try_to_autoconfigure {
+ unless ($config) {
+ my %config;
+ require ExtUtils::PkgConfig;
+- %config = ExtUtils::PkgConfig->find ("$prefix/lib/pkgconfig/gdlib.pc") if $prefix;
++ %config = ExtUtils::PkgConfig->find ("$lib_gd_path/pkgconfig/gdlib.pc") if $prefix;
+ %config = ExtUtils::PkgConfig->find ("gdlib") unless %config;
+ return unless %config;
+ $version = $config{modversion};