summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-01-14 15:59:43 -0700
committerChristoph Junghans <junghans@gentoo.org>2017-01-14 15:59:43 -0700
commit88574c92096bcac3e712e16a74b291f78ae3959b (patch)
tree86d9ce15dc9dca642a653af36962a6ea01061b4d
parentsci-visualization/gnuplot: Version bump to 5.0.5, EAPI bump 5 -> 6 (diff)
downloadgentoo-88574c92096bcac3e712e16a74b291f78ae3959b.tar.gz
gentoo-88574c92096bcac3e712e16a74b291f78ae3959b.tar.bz2
gentoo-88574c92096bcac3e712e16a74b291f78ae3959b.zip
sci-visualization/gnuplot: update live ebuilds
Package-Manager: portage-2.3.0
-rw-r--r--sci-visualization/gnuplot/gnuplot-5.0.9999.ebuild24
-rw-r--r--sci-visualization/gnuplot/gnuplot-5.1.9999.ebuild20
2 files changed, 20 insertions, 24 deletions
diff --git a/sci-visualization/gnuplot/gnuplot-5.0.9999.ebuild b/sci-visualization/gnuplot/gnuplot-5.0.9999.ebuild
index 0fa06f2b6d5a..b5c6063ab674 100644
--- a/sci-visualization/gnuplot/gnuplot-5.0.9999.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-5.0.9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit autotools eutils flag-o-matic multilib readme.gentoo-r1 toolchain-funcs wxwidgets
+inherit autotools flag-o-matic readme.gentoo-r1 toolchain-funcs wxwidgets
DESCRIPTION="Command-line driven interactive plotting program"
HOMEPAGE="http://www.gnuplot.info/"
@@ -22,7 +22,7 @@ if [[ -z ${PV%%*9999} ]]; then
else
MY_P="${P/_/.}"
SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-aix ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="gnuplot bitmap? ( free-noncomm )"
@@ -67,10 +67,10 @@ GP_VERSION="${PV%.*}"
E_SITEFILE="lisp/50${PN}-gentoo.el"
TEXMF="${EPREFIX}/usr/share/texmf-site"
-src_prepare() {
- # Fix underlinking
- epatch "${FILESDIR}"/${PN}-5.0.1-fix-underlinking.patch
+PATCHES=( "${FILESDIR}"/${PN}-5.0.1-fix-underlinking.patch )
+src_prepare() {
+ default
if [[ -z ${PV%%*9999} ]]; then
local dir
for dir in config demo m4 term tutorial; do
@@ -84,9 +84,7 @@ src_prepare() {
# hacky workaround
# Please hack the buildsystem if you like
- if use prefix && use qt4; then
- append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir)/qt4
- fi
+ use prefix && use qt4 && append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir)/qt4
DOC_CONTENTS='Gnuplot no longer links against pdflib, see the ChangeLog
for details. You can use the "pdfcairo" terminal for PDF output.'
@@ -100,7 +98,7 @@ src_prepare() {
environment variables. See the FAQ file in /usr/share/doc/${PF}/
for more information.'
- mv configure.in configure.ac || die
+ mv configure.{in,ac} || die
eautoreconf
# Make sure we don't mix build & host flags.
@@ -180,8 +178,8 @@ src_install () {
# Demo files
insinto /usr/share/${PN}/${GP_VERSION}
doins -r demo
- rm -f "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/Makefile*
- rm -f "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/binary*
+ rm -f "${ED%/}"/usr/share/${PN}/${GP_VERSION}/demo/Makefile*
+ rm -f "${ED%/}"/usr/share/${PN}/${GP_VERSION}/demo/binary*
fi
if use doc; then
diff --git a/sci-visualization/gnuplot/gnuplot-5.1.9999.ebuild b/sci-visualization/gnuplot/gnuplot-5.1.9999.ebuild
index bb9c3a160fc5..a8e8c6b05a1f 100644
--- a/sci-visualization/gnuplot/gnuplot-5.1.9999.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-5.1.9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit autotools eutils flag-o-matic multilib readme.gentoo-r1 toolchain-funcs wxwidgets
+inherit autotools flag-o-matic readme.gentoo-r1 toolchain-funcs wxwidgets
DESCRIPTION="Command-line driven interactive plotting program"
HOMEPAGE="http://www.gnuplot.info/"
@@ -22,7 +22,7 @@ if [[ -z ${PV%%*9999} ]]; then
else
MY_P="${P/_/.}"
SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-aix ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="gnuplot bitmap? ( free-noncomm )"
@@ -68,13 +68,12 @@ E_SITEFILE="lisp/50${PN}-gentoo.el"
TEXMF="${EPREFIX}/usr/share/texmf-site"
src_prepare() {
+ default
if [[ -z ${PV%%*9999} ]]; then
local dir
for dir in config demo m4 term tutorial; do
emake -C "$dir" -f Makefile.am.in Makefile.am
done
- else
- epatch "${FILESDIR}/${PN}-5.0_rc1-libcerf.patch"
fi
# Add special version identification as required by provision 2
@@ -83,9 +82,7 @@ src_prepare() {
# hacky workaround
# Please hack the buildsystem if you like
- if use prefix && use qt4; then
- append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir)/qt4
- fi
+ use prefix && use qt4 && append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir)/qt4
DOC_CONTENTS='Gnuplot no longer links against pdflib, see the ChangeLog
for details. You can use the "pdfcairo" terminal for PDF output.'
@@ -99,6 +96,7 @@ src_prepare() {
environment variables. See the FAQ file in /usr/share/doc/${PF}/
for more information.'
+ mv configure.{in,ac} || die
eautoreconf
# Make sure we don't mix build & host flags.
@@ -178,8 +176,8 @@ src_install () {
# Demo files
insinto /usr/share/${PN}/${GP_VERSION}
doins -r demo
- rm -f "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/Makefile*
- rm -f "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/binary*
+ rm -f "${ED%/}"/usr/share/${PN}/${GP_VERSION}/demo/Makefile*
+ rm -f "${ED%/}"/usr/share/${PN}/${GP_VERSION}/demo/binary*
fi
if use doc; then