summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-05-01 14:37:26 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-05-01 15:08:55 -0500
commit886ddb1b6e81ed45d6de2a98a4f00cb557b28891 (patch)
treed1d45e58fb3285daa3604242fea6fd4d4ed36bdc
parentlicenses: Remove unused licenses. (diff)
downloadgentoo-886ddb1b.tar.gz
gentoo-886ddb1b.tar.bz2
gentoo-886ddb1b.zip
app-emulation/spice: version bump to 0.13.1, bug #580570, bug #580084
This also fixes the compilation issue in 0.13.0 reported in bug #580084. Package-Manager: portage-2.2.26
-rw-r--r--app-emulation/spice/Manifest1
-rw-r--r--app-emulation/spice/spice-0.13.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-emulation/spice/Manifest b/app-emulation/spice/Manifest
index 4d02ae787819..e91eb45e6cf7 100644
--- a/app-emulation/spice/Manifest
+++ b/app-emulation/spice/Manifest
@@ -1,2 +1,3 @@
DIST spice-0.12.6.tar.bz2 1181088 SHA256 f148ea30135bf80a4f465ce723a1cd6d4ccb34c098b6298a020b378ace8569b6 SHA512 877d9c447a09055c61db7839ae1a2bbd97ab1178d8fd30fff83883064f8a2f269479649e696732095833ed3fda2d0cc0cbe2a420decb89d36d2cf2f18ad9a3db WHIRLPOOL e381cf469a29be9a91ab442ee5f426a44ee569528d9297401df1c927cbf558e9daee7709cd69a4cc6389481b0c5aa26b19e56f0e97576e270d768842581544fe
DIST spice-0.13.0.tar.bz2 1215334 SHA256 4862e2d11da10abdf46dd6cc834d79fa4ef3490efac8dbcdd19fa96f81147bbb SHA512 be9960e8f40415f2d0c2445aca701729f904b4598492b64993fc53b2cfb27652642f11721b43c44c953e6ba4982865b15260c995bb12c4f29ea9c7e962043795 WHIRLPOOL 88d92a4498e76eb279c073e4da87a0b0efe7697f6da1211b4830681a1cc6c828809dcaaec54e0876766a8fd4365e55439910c13c03e7a50d0ccbdcf98bbec781
+DIST spice-0.13.1.tar.bz2 1245323 SHA256 9ecb130424da02e90c235c1294f6e759d7c676c5e710587a5c98a1f20f991da2 SHA512 a8e65cc02c802686f2e0c21615401e13b337e050c40938bebefa684abc1ce0e2d478136d0fec481a8ee30ed98f2e2fb909dfbf6cd65e9dfd7093d59f825b95d5 WHIRLPOOL 068d7d26f18435995546d84b0d8d81ced4973773303463e597cf05e1c5accd9ac8554f22032eb55827bebbe6c0fc14915455da24c58fc70b135d955fe3442db7
diff --git a/app-emulation/spice/spice-0.13.1.ebuild b/app-emulation/spice/spice-0.13.1.ebuild
new file mode 100644
index 000000000000..46d50a86f10d
--- /dev/null
+++ b/app-emulation/spice/spice-0.13.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit eutils python-any-r1
+
+DESCRIPTION="SPICE server"
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl sasl smartcard static-libs"
+
+# the libspice-server only uses the headers of libcacard
+RDEPEND="
+ >=dev-libs/glib-2.22:2[static-libs(+)?]
+ >=media-libs/celt-0.5.1.1:0.5.1[static-libs(+)?]
+ media-libs/opus[static-libs(+)?]
+ sys-libs/zlib[static-libs(+)?]
+ virtual/jpeg:0=[static-libs(+)?]
+ >=x11-libs/pixman-0.17.7[static-libs(+)?]
+ !libressl? ( dev-libs/openssl:0[static-libs(+)?] )
+ libressl? ( dev-libs/libressl[static-libs(+)?] )
+ smartcard? ( >=app-emulation/libcacard-0.1.2 )
+ sasl? ( dev-libs/cyrus-sasl[static-libs(+)?] )"
+
+DEPEND="
+ ~app-emulation/spice-protocol-0.12.11
+ virtual/pkgconfig
+ $(python_gen_any_dep '
+ >=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ')
+ smartcard? ( app-emulation/qemu[smartcard] )
+ ${RDEPEND}"
+
+python_check_deps() {
+ has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
+ has_version "dev-python/six[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && python-any-r1_pkg_setup
+}
+
+# maintainer notes:
+# * opengl support is currently broken
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with sasl) \
+ $(use_enable smartcard) \
+ --disable-gui
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}