summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-03 20:13:20 -0400
committerMike Gilbert <floppym@gentoo.org>2016-11-03 21:05:57 -0400
commit888019eba87e0abe546eb316d24276274cbde3de (patch)
treef25eb9486387184717414675be5981e4aba59523
parentsys-apps/systemd: add sample nsswitch.conf (diff)
downloadgentoo-888019eba87e0abe546eb316d24276274cbde3de.tar.gz
gentoo-888019eba87e0abe546eb316d24276274cbde3de.tar.bz2
gentoo-888019eba87e0abe546eb316d24276274cbde3de.zip
sys-apps/systemd: enable pam for non-native abis
Package-Manager: portage-2.3.2_p3
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 58358687988d..ee96554a03f0 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -53,7 +53,7 @@ COMMON_DEPEND=">=sys-apps/util-linux-2.27.1:0=[${MULTILIB_USEDEP}]
lz4? ( >=app-arch/lz4-0_p131:0=[${MULTILIB_USEDEP}] )
lzma? ( >=app-arch/xz-utils-5.0.5-r1:0=[${MULTILIB_USEDEP}] )
nat? ( net-firewall/iptables:0= )
- pam? ( virtual/pam:= )
+ pam? ( virtual/pam:=[${MULTILIB_USEDEP}] )
qrcode? ( media-gfx/qrencode:0= )
seccomp? ( >=sys-libs/libseccomp-2.3.1:0= )
selinux? ( sys-libs/libselinux:0= )
@@ -241,7 +241,7 @@ multilib_src_configure() {
$(use_enable lz4)
$(use_enable lzma xz)
$(multilib_native_use_enable nat libiptc)
- $(multilib_native_use_enable pam)
+ $(use_enable pam)
$(multilib_native_use_enable policykit polkit)
$(multilib_native_use_enable qrcode qrencode)
$(multilib_native_use_enable seccomp)
@@ -284,10 +284,14 @@ multilib_src_compile() {
if multilib_is_native_abi; then
emake "${mymakeopts[@]}"
else
- echo 'gentoo: $(BUILT_SOURCES)' | \
- emake "${mymakeopts[@]}" -f Makefile -f - gentoo
- echo 'gentoo: $(lib_LTLIBRARIES) $(rootlib_LTLIBRARIES) $(pkgconfiglib_DATA)' | \
- emake "${mymakeopts[@]}" -f Makefile -f - gentoo
+ emake built-sources
+ local targets=(
+ '$(rootlib_LTLIBRARIES)'
+ '$(lib_LTLIBRARIES)'
+ '$(pamlib_LTLIBRARIES)'
+ '$(pkgconfiglib_DATA)'
+ )
+ echo "gentoo: ${targets[*]}" | emake "${mymakeopts[@]}" -f Makefile -f - gentoo
fi
}
@@ -311,11 +315,11 @@ multilib_src_install() {
emake "${mymakeopts[@]}" install
else
mymakeopts+=(
- install-libLTLIBRARIES
install-rootlibLTLIBRARIES
+ install-libLTLIBRARIES
+ install-pamlibLTLIBRARIES
install-pkgconfiglibDATA
install-includeHEADERS
- # safe to call unconditionally, 'installs' empty list
install-pkgincludeHEADERS
)