summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-10-28 10:41:02 -0400
committerMike Gilbert <floppym@gentoo.org>2016-10-28 10:42:12 -0400
commit8893bf6be79062f3ac90c1a74a560d96dab1ae9f (patch)
tree2746ca0f285d368b5867614b922f6b4a50602fe0
parentapp-crypt/qca: remove old (diff)
downloadgentoo-8893bf6be79062f3ac90c1a74a560d96dab1ae9f.tar.gz
gentoo-8893bf6be79062f3ac90c1a74a560d96dab1ae9f.tar.bz2
gentoo-8893bf6be79062f3ac90c1a74a560d96dab1ae9f.zip
dev-python/pyserial: bump to 3.2.1
Bug: https://bugs.gentoo.org/597326 Package-Manager: portage-2.3.2
-rw-r--r--dev-python/pyserial/Manifest1
-rw-r--r--dev-python/pyserial/files/mapping.patch4
-rw-r--r--dev-python/pyserial/pyserial-3.2.1.ebuild45
3 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/pyserial/Manifest b/dev-python/pyserial/Manifest
index 44e16e7e30b5..892f376aa30e 100644
--- a/dev-python/pyserial/Manifest
+++ b/dev-python/pyserial/Manifest
@@ -1,2 +1,3 @@
DIST pyserial-2.7.tar.gz 122081 SHA256 3542ec0838793e61d6224e27ff05e8ce4ba5a5c5cc4ec5c6a3e8d49247985477 SHA512 3fc8d9425a47ebcd37db1fcc58182854b48c9abd6642f35fba2d21458d864ae448105d704dc0d880832ba7516fa16f108f24363bd5fa9f083ea79a4ac614339b WHIRLPOOL ae6b4df86220617f7fbc1f1e4085a7e85dca645a6d84339163b40fc7a15f14b879ef7a729d3d23d0300f9ee04b21d6c24d13a791d520aef3f3ad141c6acd9b68
DIST pyserial-3.1.1.tar.gz 147535 SHA256 d657051249ce3cbd0446bcfb2be07a435e1029da4d63f53ed9b4cdde7373364c SHA512 05b6f893454b187757c8d01c8d3951751ba93e87aafd474fa684a24198eed22f892181bcbab40101e74b25dae612116880690e800adedaf56a5c12775ed2b8d8 WHIRLPOOL d9d4b4894c94da9a357b27eb5e32766c0ff46cac751667f2f2195ca82ae2a2095a9df3ba219c10818faebd420912250a0dfcc6e86aedb7c4feaf6f553cdf4d52
+DIST pyserial-3.2.1.tar.gz 147338 SHA256 1eecfe4022240f2eab5af8d414f0504e072ee68377ba63d3b6fe6e66c26f66d1 SHA512 8d3e580cc7781fc6549ab6e408642f4321eb90aafbe593f5dcf953001730f89ee32ce6592728764027a7944bfe4a0ebe2cfac1fce071777aac7c4f27ac94ab7f WHIRLPOOL 529c4eb12adf88579d528d3bd9dfec6fd7b43890217392677b7c8428f7ca7b3fe5dded863c4690c9eaa5ea37a2cdb56744e328a47a4b89d5440becceb983ecb8
diff --git a/dev-python/pyserial/files/mapping.patch b/dev-python/pyserial/files/mapping.patch
index bd315d98f040..dfcb4731bbbd 100644
--- a/dev-python/pyserial/files/mapping.patch
+++ b/dev-python/pyserial/files/mapping.patch
@@ -1,6 +1,6 @@
diff -ur pyserial-2.7.orig/documentation/conf.py pyserial-2.7/documentation/conf.py
---- documentation/conf.py 2013-10-18 00:29:53.000000000 +0800
-+++ documentation/conf.py 2014-03-28 12:41:08.848807687 +0800
+--- a/documentation/conf.py 2013-10-18 00:29:53.000000000 +0800
++++ b/documentation/conf.py 2014-03-28 12:41:08.848807687 +0800
@@ -192,9 +192,3 @@
# If false, no module index is generated.
diff --git a/dev-python/pyserial/pyserial-3.2.1.ebuild b/dev-python/pyserial/pyserial-3.2.1.ebuild
new file mode 100644
index 000000000000..223db2b08f67
--- /dev/null
+++ b/dev-python/pyserial/pyserial-3.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Serial Port extension"
+HOMEPAGE="https://github.com/pyserial/pyserial https://pypi.python.org/pypi/pyserial"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc examples"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+# Usual avoid d'loading un-needed objects.inv file
+PATCHES=( "${FILESDIR}"/mapping.patch )
+
+DOCS=( CHANGES.rst README.rst )
+
+python_compile_all() {
+ use doc && emake -C documentation html
+}
+
+python_test() {
+ ${EPYTHON} test/run_all_tests.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/_build/html/. )
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}