summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-10-22 00:02:51 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-10-22 00:02:51 +0200
commit8895d3752009bcdaa286b2a75f2926c161ed64b1 (patch)
treeb085f2ca44274bbc60181643728933eecbd5c5ab
parentsys-apps/merge-usr: add 2 (diff)
downloadgentoo-8895d3752009bcdaa286b2a75f2926c161ed64b1.tar.gz
gentoo-8895d3752009bcdaa286b2a75f2926c161ed64b1.tar.bz2
gentoo-8895d3752009bcdaa286b2a75f2926c161ed64b1.zip
net-irc/znc-palaver: add 1.2.2
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--net-irc/znc-palaver/Manifest1
-rw-r--r--net-irc/znc-palaver/znc-palaver-1.2.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/net-irc/znc-palaver/Manifest b/net-irc/znc-palaver/Manifest
index b1dc595c2cc7..bff72c1e0f33 100644
--- a/net-irc/znc-palaver/Manifest
+++ b/net-irc/znc-palaver/Manifest
@@ -1 +1,2 @@
DIST znc-palaver-1.2.1.tar.gz 13302 BLAKE2B 0a46e4dd93f06a2b1705d619b0960a246ebf326fe4ca1afdc152a90274984421478ff52bd942a09dffe58349477d622b2839b2e1af0cb11b5bc8c7a329d3b3a4 SHA512 0cfa4dfcebca79ed0aaa9b44c7395318782237a8752e26810686276587004ab95342f5983e6c9a74950da062c34e634d8a4bf502977289e59686eef069dca84a
+DIST znc-palaver-1.2.2.tar.gz 14649 BLAKE2B ad67bbbfc9ad293ce71669d84b7ccb3bd69f52e534662ac35c4a3ecd41fe91af2fe519f109dd2e9b9b824e5970883706a6dc7ebc89b806e74e5ad121466947f8 SHA512 b91ba7200cac393557252874293f131c83a4cea83203457e8f6f91a129d8207c16951b983e52848ce4f54750752f69765ca26b8e3f50e74da2a11138eaf2bdce
diff --git a/net-irc/znc-palaver/znc-palaver-1.2.2.ebuild b/net-irc/znc-palaver/znc-palaver-1.2.2.ebuild
new file mode 100644
index 000000000000..a02f04fc7453
--- /dev/null
+++ b/net-irc/znc-palaver/znc-palaver-1.2.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit python-single-r1 toolchain-funcs
+
+DESCRIPTION="A ZNC module which provides push notifications to Palaver"
+HOMEPAGE="https://github.com/cocodelabs/znc-palaver"
+SRC_URI="https://github.com/cocodelabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ net-irc/znc:=[ssl]"
+
+BDEPEND="
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/semantic_version[${PYTHON_USEDEP}]
+ ')
+"
+
+DOCS=( "CHANGELOG.md" "README.md" )
+
+src_compile() {
+ tc-export CXX
+
+ # Building znc modules by 'znc-buildmod'
+ # does not support multiple threads.
+ emake -j1
+}
+
+src_test() {
+ default
+
+ emake test-integration
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/znc
+ doins palaver.so
+
+ einstalldocs
+}